summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpriponne2017-05-02 14:21:29 +0100
committerpriponne2017-05-02 14:21:29 +0100
commit4dd628f4765ef7abf6d78ce48cf35d8c69930649 (patch)
treefb3e174368bd89deec0cdb49f8b3b449535c5167 /PKGBUILD
parentb6c929f5879b9753f575aa8fe644ce665f1ff75a (diff)
downloadaur-4dd628f4765ef7abf6d78ce48cf35d8c69930649.tar.gz
Updated to 3.24.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 28 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31b1c0538027..42fcc6d0c7aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,45 +2,49 @@
# Maintainer: Kresimir Pripuzic <kpripuzic@gmail.com>
pkgname=file-roller-tmp
-pkgver=3.16.4
+pkgver=3.24.1
pkgrel=1
pkgdesc="The file-roller with an additional patch to put temporary files in /tmp instead of ~/.cache (and thus to reduce the amount of writes to SSDs)."
-arch=('i686' 'x86_64')
-license=('GPL')
-depends=('desktop-file-utils' 'gtk3' 'hicolor-icon-theme' 'dconf' 'libarchive' 'file' 'json-glib' 'libnotify' 'zip' 'unzip')
-makedepends=('intltool' 'pkg-config' 'libnautilus-extension' 'itstool' 'docbook-xsl')
+arch=(i686 x86_64)
+license=(GPL)
+depends=(gtk3 dconf libarchive file json-glib libnotify zip unzip)
+makedepends=(intltool itstool docbook-xsl gnome-common git libnautilus-extension)
optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
'unrar: better RAR archive support'
'unace: ACE archive support'
- 'lrzip: lrzip archive support'
- 'cdrkit: ISO image support')
-groups=('gnome-extra')
+ 'lrzip: lrzip archive support')
+groups=(gnome-extra)
provides=('file-roller')
conflicts=('file-roller')
-options=('!emptydirs')
-install=file-roller.install
-url="http://www.gnome.org"
-source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname:0:11}/${pkgver:0:4}/${pkgname:0:11}-$pkgver.tar.xz
- tmp-as-temp.patch)
-sha256sums=('5455980b2c9c7eb063d2d65560ae7ab2e7f01b208ea3947e151680231c7a4185'
- '9556742b38c06f131f7d56eb72522e38402a85ec99904be73ccae228f5b9572f')
+_commit=e6ef6fa43a6d5d6e1509f122a206870adc113563 # tags/3.24.1^0
+source=("git+https://git.gnome.org/browse/file-roller#commit=$_commit"
+ tmp-as-temp.patch)
+sha256sums=('SKIP'
+ '753c6ee41772677b115f4178fe6384c21d8aa5d489a6074f659d5305736acf57')
+
+pkgver() {
+ cd ${pkgname:0:11}
+ git describe --tags | sed 's/-/+/g'
+}
prepare() {
- cd ${pkgname:0:11}-$pkgver
- patch -Np1 -i ../tmp-as-temp.patch
+ cd ${pkgname:0:11}
+ NOCONFIGURE=1 ./autogen.sh
+
+ #patch
+ cd $srcdir/${pkgname:0:11}
+ patch -Np0 -i ../tmp-as-temp.patch
}
build() {
- cd ${pkgname:0:11}-$pkgver
-
- ./configure --prefix=/usr --sysconfdir=/etc \
- --libexecdir=/usr/lib/file-roller \
- --localstatedir=/var --disable-static \
- --disable-schemas-compile
+ cd ${pkgname:0:11}
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --libexecdir=/usr/lib/$pkgname --disable-static --disable-schemas-compile
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
- cd ${pkgname:0:11}-$pkgver
+ cd ${pkgname:0:11}
make DESTDIR="$pkgdir" install
}