summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhashworks2020-03-24 20:18:42 +0100
committerhashworks2020-03-24 20:18:42 +0100
commitfc1562431d1a22a92e8c3e9dc85877ee8361bfb8 (patch)
tree07b56d258ed56fb5caf586bdf6b13f6f484e3c3d /PKGBUILD
parent6843d5e9b075bc73955a8907bdc084df798fec74 (diff)
downloadaur-fc1562431d1a22a92e8c3e9dc85877ee8361bfb8.tar.gz
Add systemd timers and php-fpm example config
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 19 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b3ff1cd904f..8cde2f29cdab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: hashworks<mail@hashworks.net>
pkgname=filebin
pkgver=3.4.3
-pkgrel=1
+pkgrel=2
pkgdesc="A pastebin service written in PHP"
arch=('any')
url="https://wiki.server-speed.net/projects/filebin"
@@ -22,9 +22,19 @@ install=filebin.install
options=('!strip' 'emptydirs')
source=("git+https://github.com/Bluewind/filebin.git"
'filebin-nginx.conf'
+ 'filebin-php-fpm.conf'
+ 'filebin-file-cron.service'
+ 'filebin-file-cron.timer'
+ 'filebin-user-cron.service'
+ 'filebin-user-cron.timer'
)
sha256sums=('SKIP'
- '5500d423d798478bf4f7bb0a147fe8a42b00e843513dd70665ec81f304a6c729')
+ '6ed404a3fbc28c6ab35bf1eba67ddcf46cfd48893237155e38d297a13020180c'
+ '034442098d1608807bec2a03028a7c8bb9ae9d286c378e2f668b4aca3cc9d4e1'
+ '78dd850467d89ac3d1b57fa72fe9ce8d736ce29a89abe624d9c4d2e168e59d19'
+ '116b1e5031c22ad251c486b18ff203813f7227197ef853927ddc2de00e85cbe1'
+ '36c82c506a058edc50b882200332c6a540aa68a5749919eb62dc6c633c47deb3'
+ 'd73e4b984ab95954bd18e08237c6aa8bec32ccc5699531727362e2c75ba9c25e')
build () {
cd ${srcdir}/filebin
@@ -36,8 +46,10 @@ build () {
package() {
mkdir -p ${pkgdir}/usr/share/webapps
mkdir -p ${pkgdir}/etc/webapps/filebin
+ mkdir -p ${pkgdir}/usr/lib/systemd/system
cp -ra ${srcdir}/filebin/ ${pkgdir}/usr/share/webapps/filebin/
- cp filebin-nginx.conf ${pkgdir}/usr/share/webapps/filebin
+ cp filebin-file-cron.service filebin-file-cron.timer filebin-user-cron.service filebin-user-cron.timer ${pkgdir}/usr/lib/systemd/system
+ cp filebin-nginx.conf filebin-php-fpm.conf ${pkgdir}/usr/share/webapps/filebin
cd ${pkgdir}/usr/share/webapps/filebin
cp application/config/example/{config-local,database,memcached}.php ${pkgdir}/etc/webapps/filebin
rm application/config/memcached.php
@@ -45,8 +57,12 @@ package() {
cp data/local/examples/contact-info.php ${pkgdir}/etc/webapps/filebin
ln -s /etc/webapps/filebin/contact-info.php data/local
+ # http
+ chown 33:33 ${pkgdir}/usr/share/webapps/filebin/data/uploads
+
# removing unnecessary data for a production environment
rm -rf .git
+ rm -rf git-hooks
rm -rf application/third_party/{test-more-php,mockery}
rm -rf application/tests
find . -name \*.gitignore -type f -delete