summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormax.bra2018-04-06 13:28:52 +0200
committermax.bra2018-04-06 13:28:52 +0200
commit18de967e2ef435793bcd65ed60cf3c82785807c3 (patch)
treef18de804a20f33908be15f72664acde37e746d24 /PKGBUILD
parentc2d2c76c5b11c239f371897a2572e17eb2733d48 (diff)
downloadaur-18de967e2ef435793bcd65ed60cf3c82785807c3.tar.gz
api keys added
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63b88b8e1eb1..efbac1505f5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: max.bra <max dot bra at alice dot it>
# Contributor: nadolph
+# Contributor: dcelasun
# Contributor: said
-# Contributor: Kaurin <milos dot kaurin at gmail>
+# Contributor: Kaurin <milos dot kaurin at gmail>
# Contributor: Nathan Owe <ndowens04 at gmail>
pkgname=filebot
pkgver=4.8.0
-pkgrel=2
+pkgrel=3
_jnaver=4.5.1
pkgdesc="The ultimate tool to rename TV/anime shows, download subtitles, and validate checksums."
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
@@ -28,7 +29,7 @@ source=("${pkgname}::git+https://github.com/filebot/filebot.git"
md5sums=('SKIP'
'3cf5c206ba2246386af2e9248fa6f035'
- '81b701ce1a1b52226f432aa86c6e1386'
+ '38c3f0029e094043cfca147981d41081'
'04f46be047049448dba3f0de29fe192d'
'f37edd0bba7570904d28ab1681c7a7f3')
@@ -44,6 +45,15 @@ prepare() {
sed -i -E 's/release="([^"]*)"/target="\1" source="\1"/' build.xml
sed -i -E 's/jre.version: 10/jre.version: 9/' app.properties
sed -i -E 's/jvm.version: 10/jvm.version: 9/' app.properties
+cat <<EOT >> app.properties
+url.data: https://app.filebot.net/data
+apikey.fanart.tv: BA864DEE427E384A
+apikey.thetvdb: BA864DEE427E384A
+apikey.themoviedb: 66308fb6e3fd850dde4c7d21df2e8306
+apikey.omdb: 49d311ec
+apikey.acoustid: 0B3qZnQc
+apikey.anidb: filebot
+EOT
cd "$srcdir/jna-$_jnaver/lib/native/"
unzip linux-$_intarch.jar 2>&1 >/dev/null
}