summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2021-03-16 06:22:20 +0800
committerlilac2021-03-16 06:22:20 +0800
commit1153bf272120feb2a73df94363cf3bbcc10cdae2 (patch)
treef7f45a5180576e3d3cddeb754d8e7e4791f4c3ce /PKGBUILD
parent47111837870a22209717f34995ac776829c06348 (diff)
downloadaur-1153bf272120feb2a73df94363cf3bbcc10cdae2.tar.gz
[lilac] updated to 2.13.0-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 793bda909a8d..a7f0abe898b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,34 @@
# Contributor: Sherlock Holo <sherlockya(at)gmail.com>
pkgname=filebrowser-bin
pkgver=2.13.0
-pkgrel=1
+pkgrel=3
pkgdesc="Web File Manager which can be used as a middleware or standalone app."
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/filebrowser/filebrowser"
license=('Apache')
#depends=('glibc')
provides=("filebrowser")
conflicts=("filebrowser")
-install="$pkgname.install"
+install="${pkgname}.install"
source=('filebrowser@.service' 'filebrowser-bin.install'
'https://raw.githubusercontent.com/hacdias/filebrowser/master/LICENSE')
-
-source_x86_64=(linux-amd64-filebrowser-$pkgver.tar.gz::https://github.com/filebrowser/filebrowser/releases/download/v$pkgver/linux-amd64-filebrowser.tar.gz)
+source_x86_64=("linux-amd64-filebrowser-${pkgver}.tar.gz::https://github.com/filebrowser/filebrowser/releases/download/v${pkgver}/linux-amd64-filebrowser.tar.gz")
+source_aarch64=("linux-aarch64-filebrowser-${pkgver}.tar.gz::https://github.com/filebrowser/filebrowser/releases/download/v${pkgver}/linux-arm64-filebrowser.tar.gz")
sha256sums=('79a1fdb1f0b26f211242f1fdb6f3478a56890a721fe324ea7ade2e8f9a351b38'
'8a423af0707ac37b15ca425ec097b3d98aecd08238f7599ae9dfcce31c8cbb32'
'1fc20cab3a7d67d7997126a98dd151a362dc4600201ca37fd608b959d25985db')
sha256sums_x86_64=('e0b6ce6588446e93246b960e64884aa6bb2d1424879f3b57c44be41ce54ea834')
+sha256sums_aarch64=('658e9e04a2dd07e025a98d9b05f92b4cce797d10798af66e46be01960fce9c94')
+
+
package() {
- install -Dm644 filebrowser@.service ${pkgdir}/usr/lib/systemd/system/filebrowser@.service
- install -Dm755 LICENSE ${pkgdir}/usr/share/licenses/filebrowser-bin/LICENSE
- install -Dm755 $srcdir/filebrowser ${pkgdir}/usr/bin/filebrowser
+ install -Dm644 filebrowser@.service "${pkgdir}/usr/lib/systemd/system/filebrowser@.service"
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/filebrowser-bin/LICENSE"
+ install -Dm755 "${srcdir}/filebrowser" "${pkgdir}/usr/bin/filebrowser"
}
+
# vim set: ts=4 sw=4 et: