summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSaultDon2016-08-09 11:16:14 -0700
committerSaultDon2016-08-09 11:16:14 -0700
commit8a9b481c8e8f51121d6c805a7a14441eb641f6bc (patch)
treebb2a1c83486ba33bb6af4f7e7e2040da95c06d19 /PKGBUILD
parenta5521d0dc9f35547381873ba08a072c3a39fcad9 (diff)
downloadaur-8a9b481c8e8f51121d6c805a7a14441eb641f6bc.tar.gz
1.4-2, incorporated old abi patch from striges1111
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index afbfcb34aaef..c54340f4a12d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=filegdb-api
_pkgname=FileGDB_API
pkgver=1.4
-pkgrel=1
+pkgrel=2
pkgdesc="ESRI File Geodatabase (FileGDB) API"
arch=('i686' 'x86_64')
url="http://www.esri.com/apps/products/download/#File_Geodatabase_API_1.3"
@@ -35,6 +35,9 @@ build() {
#Setup LD_LIBRARY_PATH
export LD_LIBRARY_PATH=$srcdir/${pkgname}/lib:$LD_LIBRARY_PATH
+ #Modify make.include to use old ABI
+ cd "$srcdir/${pkgname}/include"
+ sed -i '/-D_LARGEFILE64_SOURCE/ s/$/ -D_GLIBCXX_USE_CXX11_ABI=0/' make.include
#Building all samples
cd "$srcdir/${pkgname}/samples"
@@ -44,8 +47,8 @@ build() {
cd "$srcdir/${pkgname}/samples/ProcessTopologies"
# Insert libxml2 library path to Makefile
- sed -i '/^CXXFLAGS=/ s/$/ -I\/usr\/include\/libxml2\//' Makefile
- make
+ #sed -i '/^CXXFLAGS=/ s/$/ -I\/usr\/include\/libxml2\//' Makefile
+ #make
}
# Uncomment check() portion if you want to perform sample tests