summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShai Jo2018-02-27 18:52:16 +0100
committerShai Jo2018-02-27 19:03:24 +0100
commit09e25138ccca8bf355157fa07a5b5438d47798f8 (patch)
treed4b6dec93511b223c875539081e6bf9c644f775b /PKGBUILD
downloadaur-09e25138ccca8bf355157fa07a5b5438d47798f8.tar.gz
copy filezilla community PKGBUILD, enable Storj support, change maintainer and generate .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7462210e28f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id$
+# Contributor: Alexander Fehr <pizzapunk gmail com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Maintainer: Shai Jo <shaiJo4U[äT]protonmail(.)com
+
+_pkgname=filezilla
+pkgname=$_pkgname-storj
+pkgver=3.31.0
+pkgrel=1
+pkgdesc="Fast and reliable Storj, FTP, FTPS and SFTP client"
+arch=('x86_64')
+url="http://filezilla-project.org/"
+license=('GPL')
+depends=('dbus' 'xdg-utils' 'wxgtk3' 'libidn' 'hicolor-icon-theme' 'sqlite' 'gnutls' 'libfilezilla' 'libstorj')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("http://downloads.sourceforge.net/project/filezilla/FileZilla_Client/${pkgver}/FileZilla_${pkgver}_src.tar.bz2")
+
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+}
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --disable-manualupdatecheck \
+ --disable-autoupdatecheck \
+ --with-pugixml=builtin \
+ --with-wx-config=/usr/bin/wx-config-gtk3 \
+ --enable-storj
+ make
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+md5sums=('0eee1369904e9b0b60500a1068ca5a85')