summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhayao2021-03-16 17:48:40 +0900
committerhayao2021-03-16 17:48:40 +0900
commitc6309d84bacdfdab01b5a58d076a5d873c7e9d75 (patch)
treeea220727ac554692fc640e1aadd326a6c111defe /PKGBUILD
parent58d84f9b13cb318db9ca5bedf466950e50b321ac (diff)
downloadaur-c6309d84bacdfdab01b5a58d076a5d873c7e9d75.tar.gz
[add] : Added unstable version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1788a93de611..e09b135cf78d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Yamada Hayao <hayao@fascode.net>
_pkgname=filezilla
-pkgname="$_pkgname-bin"
-pkgver=3.53.0
+pkgname="${_pkgname}-unstable-bin"
+pkgver=3.53.0_rc1
pkgrel=1
pkgdesc='Free, open source FTP, FTPS and SFTP client (Pre-built binary)'
arch=('i686' 'x86_64')
@@ -15,10 +15,10 @@ conflicts=("${_pkgname}" "${_pkgname}-git" "libfilezilla")
machine_arch="${CARCH}"
for _arch in ${arch[@]}; do
- eval "source_${_arch}=(FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2)"
+ eval "source_${_arch}=(FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_${pkgver//_/-}_${_arch}-linux-gnu.tar.bz2)"
eval "sha512sums_${_arch}=(
'$(
- _url="https://download.filezilla-project.org/client/FileZilla_${pkgver}.sha512"
+ _url="https://download.filezilla-project.org/client/FileZilla_${pkgver//_/-}.sha512"
_sum="$(curl --silent -L "${_url}" | grep "FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2")"
if [[ ! "${?}" = 0 ]] || [[ ! -v "_sum" ]] || [[ -z "${_sum}" ]]; then
echo -n "SKIP"