summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-09-28 11:34:01 +1300
committercaltlgin2020-09-28 11:34:01 +1300
commit41557df3bf12ea380b109c6a4ff2aac86ca2536d (patch)
tree578667b1a269284e8fbc3324de959ccd0fa3724c /PKGBUILD
downloadaur-41557df3bf12ea380b109c6a4ff2aac86ca2536d.tar.gz
Add to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc2926b6ab8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='findfileconflicts'
+pkgver=1.1.3
+pkgrel=1
+pkgdesc='Detect and solve possible file conflicts'
+arch=('x86_64')
+url='https://github.com/artemanufrij/findfileconflicts'
+license=('GPL3')
+depends=('granite')
+makedepends=('meson' 'vala')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('027d280232703a024033add4f68c7b93e8c56340ecf4a7d20dc82bdcb990bb2b')
+
+build() {
+ arch-meson "${pkgname}-${pkgver}" build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}-${pkgver}/README.md"
+}
+
+# vim: ts=2 sw=2 et: