summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Vogt2016-01-15 10:13:52 +0100
committerDavid Vogt2016-01-15 10:13:52 +0100
commitbb99d901c5f3ff38417d3c54181f4390ac04593e (patch)
treed4387bf6fab439641b8d2e183eebed839ac764c8 /PKGBUILD
downloadaur-bb99d901c5f3ff38417d3c54181f4390ac04593e.tar.gz
Initial commit - package builds, but does not work perfectly yet
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ad89dc49cee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: David Vogt <dave at winged dot ch>
+# This PKGBUILD is maintained at https://github.com/winged/aur-packages
+
+pkgname=finja-git
+_pkgname=finja-git
+pkgver=0.r11.72eb134
+pkgrel=1
+pkgdesc="Index and find your stuff"
+arch=('any')
+license=('AGPL')
+url=('http://github.com/ganwell/finja')
+depends=('python'
+ 'python-six'
+ 'python-binaryornot'
+ )
+conflicts=()
+provides=('finja' 'finja-git')
+makedepends=()
+source=("$pkgname::git://github.com/ganwell/finja.git"
+ "LICENSE::https://www.gnu.org/licenses/agpl.txt")
+sha256sums=('SKIP' '57c8ff33c9c0cfc3ef00e650a1cc910d7ee479a8bc509f6c9209a7c2a11399d6')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: