summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordr460nf1r32023-02-18 11:31:20 +0100
committerdr460nf1r32023-02-18 11:31:20 +0100
commita695a47bf1791dfc6579ff2ac34653b4e2695aab (patch)
treeaf1baca9fd244694f6f6e541fb45638bedacbd15 /PKGBUILD
parentb05e8a85b0581554969706c6067ce116de72ccda (diff)
downloadaur-a695a47bf1791dfc6579ff2ac34653b4e2695aab.tar.gz
Update 110, add some patches
Signed-off-by: dr460nf1r3 <root@dr460nf1r3.org>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a14e8529378..a76bca3d6fe7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=firedragon
_pkgname=FireDragon
-pkgver=109.0.1
+pkgver=110.0
pkgrel=1
pkgdesc="Librewolf fork build using custom branding, settings & KDE patches by OpenSUSE"
arch=(x86_64 x86_64_v3 aarch64)
@@ -40,7 +40,7 @@ source=(https://archive.mozilla.org/pub/firefox/releases/"$pkgver"/source/firefo
"librewolf-source::git+https://gitlab.com/librewolf-community/browser/source.git"
"librewolf-settings::git+https://gitlab.com/librewolf-community/settings.git"
"cachyos-source::git+https://github.com/CachyOS/CachyOS-Browser-Common.git")
-sha256sums=('5e43fdfb3923ee3a7ae7bc91ef3377a3fc6f8a0c1b87436c19b29458b0d731d9'
+sha256sums=('d3882492190e4fdcfa142772cf35de5403effb011d24357b315d643ed9168a39'
'SKIP'
'53d3e743f3750522318a786befa196237892c93f20571443fdf82a480e7f0560'
'SKIP'
@@ -167,13 +167,19 @@ END
# PGO improvements
patch -Np1 -i "${_cachyos_patches_dir}"/gentoo/0016-bmo-1516081-Disable-watchdog-during-PGO-builds.patch
+ # https://bugs.archlinux.org/task/76231
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1790496
+ # https://src.fedoraproject.org/rpms/firefox/blob/rawhide/f/libwebrtc-screen-cast-sync.patch
+ patch -Np1 -i "${_patches_dir}"/custom/libwebrtc-screen-cast-sync.patch
+
# Remove some pre-installed addons that might be questionable
patch -Np1 -i "${_librewolf_patches_dir}"/remove_addons.patch
# KDE menu and unity menubar
- patch -Np1 -i "${_librewolf_patches_dir}"/unity_kde/mozilla-kde.patch
- patch -Np1 -i "${_librewolf_patches_dir}"/unity_kde/firefox-kde.patch
- patch -Np1 -i "${_librewolf_patches_dir}"/unity_kde/unity-menubar.patch
+ patch -Np1 -i "${_cachyos_patches_dir}"/unity_kde/mozilla-kde.patch
+ patch -Np1 -i "${_cachyos_patches_dir}"/unity_kde/firefox-kde.patch
+ patch -Np1 -i "${_cachyos_patches_dir}"/unity_kde/unity-menubar.patch
+ patch -Np1 -i "${_cachyos_patches_dir}"/kde/mozilla-nongnome-proxies.patch
# Disabling Pocket
patch -Np1 -i "${_librewolf_patches_dir}"/sed-patches/disable-pocket.patch
@@ -228,12 +234,18 @@ END
# Update handler links
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/handlers.patch
- # Hide the annoying Firefox view feature introduced in 106
- # patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/firefox-view.patch
+ # Remove unified extensions recommendations
+ patch -Np1 -i "${_librewolf_patches_dir}"/unified-extensions-dont-show-recommendations.patch
+
+ # RFP Performance API - should be merged in 111
+ patch -Np1 -i "${_librewolf_patches_dir}"/rfp-performance-api.patch
# Fix telemetry removal, see https://gitlab.com/librewolf-community/browser/linux/-/merge_requests/17, for example
patch -Np1 -i "${_librewolf_patches_dir}"/disable-data-reporting-at-compile-time.patch
+ # Hide Firefox view
+ patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/firefox-view.patch
+
# Allows hiding the password manager (from the lw pref pane) / via a pref
patch -Np1 -i "${_librewolf_patches_dir}"/hide-passwordmgr.patch