summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornikatar2019-07-03 07:54:56 +0300
committernikatar2019-07-03 07:54:56 +0300
commit0511a3ffe37e1fed7c5e8e46c7252ca1bdb1327d (patch)
treef61131e1277dfa74c01d5b65bf5a97f0de41b934 /PKGBUILD
parent21ca863a079212e44c9ac72d8fc42c746d56f2b7 (diff)
downloadaur-0511a3ffe37e1fed7c5e8e46c7252ca1bdb1327d.tar.gz
67.0.4-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 34 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98a13d9af4ba..cc0db38f38eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgname=firefox-appmenu
_pkgname=firefox
-pkgver=67.0.2
-pkgrel=1
+pkgver=67.0.4
+pkgrel=2
pkgdesc="Firefox from extra with appmenu patch"
arch=(x86_64)
license=(MPL GPL LGPL)
@@ -14,7 +14,7 @@ url="https://aur.archlinux.org/packages/firefox-appmenu/"
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
ffmpeg nss ttf-font libpulse)
makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
- xorg-server-xvfb autoconf2.13 rust mercurial clang llvm jack gtk2
+ xorg-server-xvfb autoconf2.13 rust clang llvm jack gtk2
python nodejs python2-psutil cbindgen nasm)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
@@ -24,16 +24,17 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
provides=("firefox=$pkgver")
conflicts=("firefox")
options=(!emptydirs !makeflags)
-_repo=https://hg.mozilla.org/mozilla-unified
-source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
- $_pkgname.desktop firefox-symbolic.svg
+source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
"https://gitlab.com/nikatar/for-aur/raw/master/firefox-appmenu/0001-bz-1521249.patch"
+ $_pkgname.desktop firefox-symbolic.svg
unity-menubar.patch)
-sha256sums=('SKIP'
+sha256sums=('b2fb2d3e64a6947ef4f8212b72649acf2aa2cd4c8f70548abb636dd581fd6dc5'
+ 'SKIP'
+ 'd0673786a6a1f1b9f6f66a3a1356afa33f1f18f59dabd92bd193c88c52a1d04c'
'e8d2908727309a58bee9a3dc994e85140c5977b2d486381d67d5e22ad3830d28'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- 'd0673786a6a1f1b9f6f66a3a1356afa33f1f18f59dabd92bd193c88c52a1d04c'
'cf4bed830bc271d00029f23b9c66f5bfa286532be0848ce8a045fce78ff66341')
+validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@@ -47,9 +48,29 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
# more information.
_mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
+# For telemetry and crash dump analysis to work correctly, we need to tell the
+# build system which Mercurial changeset is our source. Should not be needed
+# anymore once 69 is released:
+# https://bugzilla.mozilla.org/show_bug.cgi?id=1338099
+_repo=https://hg.mozilla.org/releases/mozilla-release
+_tag=FIREFOX_${pkgver//./_}_RELEASE
+
+_changeset=ea5154beddff08b919697e3bed6f38cfe3a3d82f
+_changeset_tag=FIREFOX_67_0_4_RELEASE
+
+if [[ $1 == update_hgrev ]]; then
+ _changeset=$(hg id -r $_tag --id $_repo --template '{node}')
+ sed -e "/^_changeset=/s/=.*/=$_changeset/;/^_changeset_tag=/s/=.*/=$_tag/" \
+ -i "${BASH_SOURCE[0]}"
+ exit 0
+elif [[ $_tag != $_changeset_tag ]]; then
+ error "Changeset needs update. Run: bash PKGBUILD update_hgrev"
+ exit 1
+fi
+
prepare() {
mkdir mozbuild
- cd mozilla-unified
+ cd firefox-$pkgver
# https://bugzilla.mozilla.org/show_bug.cgi?id=1521249
patch -Np1 -i ../0001-bz-1521249.patch
@@ -80,6 +101,7 @@ export RANLIB=llvm-ranlib
ac_add_options --enable-official-branding
ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=org.archlinux
+ac_add_options --with-unsigned-addon-scopes=app,system
export MOZILLA_OFFICIAL=1
export MOZ_APP_REMOTINGNAME=${pkgname//-/}
export MOZ_TELEMETRY_REPORTING=1
@@ -105,9 +127,10 @@ END
}
build() {
- cd mozilla-unified
+ cd firefox-$pkgver
export MOZ_SOURCE_REPO="$_repo"
+ export MOZ_SOURCE_CHANGESET="$_changeset"
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
@@ -119,7 +142,7 @@ build() {
}
package() {
- cd mozilla-unified
+ cd firefox-$pkgver
DESTDIR="$pkgdir" ./mach install
find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +