summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornikatar2019-12-05 15:59:52 +0300
committernikatar2019-12-05 15:59:52 +0300
commit810ec5a79d464e51f6f58beb9ca6e822562ae868 (patch)
treefefdbbd3eefdb992920118741f856f15c7b34ef0 /PKGBUILD
parent64856db7a59807f66bf00f5359c388dfb15f135b (diff)
downloadaur-810ec5a79d464e51f6f58beb9ca6e822562ae868.tar.gz
71.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6164b3b14fe8..31b3bbcd004a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=firefox-appmenu
_pkgname=firefox
-pkgver=70.0.1
+pkgver=71.0
pkgrel=1
pkgdesc="Firefox from extra with appmenu patch"
arch=(x86_64)
@@ -25,14 +25,14 @@ provides=("firefox=$pkgver")
conflict=("firefox")
options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
- no-relinking.patch
+ https://github.com/nikatar/AUR/raw/master/firefox-appmenu_source/0001-Bug-1212502-Switch-mozinfo-to-using-the-distro-packa.patch
0001-Use-remoting-name-for-GDK-application-names.patch
$_pkgname.desktop
unity-menubar.patch)
-sha256sums=('f2e9bb26af7682b31e82fdfc3a4b3e04fd1caa8b004469ea608185d33e35691b'
+sha256sums=('78304cd58229e7103b56b34718aad051c9a4db30c266512a64f501ba58da7fbe'
'SKIP'
- '2dc9d1aa5eb7798c89f46478f254ae61e4122b4d1956d6044426288627d8a014'
- 'ab07ab26617ff76fce68e07c66b8aa9b96c2d3e5b5517e51a3c3eac2edd88894'
+ '33f5aec0bba83b23410176c5351425d2ad949d7f0bf409a579be25bebb773fce'
+ '5f7ac724a5c5afd9322b1e59006f4170ea5354ca1e0e60dab08b7784c2d8463c'
'e466789015e15be9409b7a7044353674ca6aa0f392e882217f90c79821fe2630'
'73b9804393381f2c278eff63fecbd05035264dbb2aa68dd263a14db9f981a668')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@@ -53,8 +53,8 @@ prepare() {
mkdir mozbuild
cd firefox-$pkgver
- # Avoid relinking during buildsymbols
- patch -Np1 -i ../no-relinking.patch
+ # Make it compile with Python 3.8
+ patch -Np1 -i ../0001-Bug-1212502-Switch-mozinfo-to-using-the-distro-packa.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
@@ -137,7 +137,7 @@ END
xvfb-run -a -n 92 -s "-screen 0 1600x1200x24" \
./mach python build/pgo/profileserver.py
- if ! compgen -G '*.profraw' >&2; then
+ if [[ ! -s merged.profdata ]]; then
error "No profile data produced."
return 1
fi
@@ -154,7 +154,7 @@ END
cat >.mozconfig ../mozconfig - <<END
ac_add_options --enable-lto=cross
ac_add_options --enable-profile-use=cross
-ac_add_options --with-pgo-profile-path=${PWD@Q}
+ac_add_options --with-pgo-profile-path=${PWD@Q}/merged.profdata
ac_add_options --with-pgo-jarlog=${PWD@Q}/jarlog
END
./mach build
@@ -236,5 +236,3 @@ END
cp -fvt "$startdir" {} +
fi
}
-
-# vim:set sw=2 et: