summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornikatar2018-12-25 10:49:11 +0300
committernikatar2018-12-25 10:49:11 +0300
commit8dfc052487ff71fc125e863c608e9a41ea9e4ea5 (patch)
treeb3ced685a210c17d09a50d0742dc00ed779ffa0d /PKGBUILD
parent8716eab160be2747f713bb3755e24d90eddb7efd (diff)
downloadaur-8dfc052487ff71fc125e863c608e9a41ea9e4ea5.tar.gz
64.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ee4a5d7fe89..a47e2bb9cea0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=firefox-appmenu
_pkgname=firefox
-pkgver=63.0.3
+pkgver=64.0
pkgrel=1
pkgdesc="Firefox from extra with appmenu patch"
arch=(x86_64)
@@ -31,7 +31,7 @@ source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
sha256sums=('SKIP'
'2adca824b52ab5bc6e7e4fa486c1ecb47d283832bd4b75d10494b033f1cab911'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- '722324ef522f3e2452f49924e47a2e8a3a547e18aef32d7c1252113eb839451f')
+ '18d37f79d6919d26c7f581f4c0025b556ced05362749be29af118da05f3cfb51')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@@ -63,6 +63,13 @@ ac_add_options --enable-release
ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
+ac_add_options --enable-lto
+export MOZ_PGO=1
+export CC=clang
+export CXX=clang++
+export AR=llvm-ar
+export NM=llvm-nm
+export RANLIB=llvm-ranlib
# Branding
ac_add_options --enable-official-branding
@@ -104,6 +111,9 @@ build() {
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+ # LTO needs more open files
+ ulimit -n 4096
+
./mach build
./mach buildsymbols
}