summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornikatar2018-10-25 14:45:55 +0300
committernikatar2018-10-25 14:45:55 +0300
commitaca2510fa6ca665767c0baf64b18408134ae4e4c (patch)
tree093e9c1f19835f93d199813e9e3ab45281bce260 /PKGBUILD
parentec76439bedd400878be9c5227995f38596c9ba26 (diff)
downloadaur-aca2510fa6ca665767c0baf64b18408134ae4e4c.tar.gz
updated to 63.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c69de61ecbce..120e151a44ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,17 @@
pkgname=firefox-appmenu
_pkgname=firefox
-pkgver=62.0.3
-pkgrel=1
-pkgdesc="Firefox from extra with appemnu patch"
+pkgver=63.0
+pkgrel=2
+pkgdesc="Firefox from extra with appmenu patch"
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://aur.archlinux.org/packages/firefox-appmenu/"
-depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
- nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
-makedepends=(unzip zip diffutils python2 yasm mesa imake inetutils xorg-server-xvfb
- autoconf2.13 rust mercurial clang llvm jack gtk2 python)
+depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
+ ffmpeg nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
+makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
+ xorg-server-xvfb autoconf2.13 rust mercurial clang llvm jack gtk2
+ python nodejs python2-psutil cbindgen)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@@ -29,7 +30,7 @@ source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
sha256sums=('SKIP'
'2adca824b52ab5bc6e7e4fa486c1ecb47d283832bd4b75d10494b033f1cab911'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- '36fa25a8660302d7b8e2eca119e70116470708246a659caebcb1704090d518bf')
+ '722324ef522f3e2452f49924e47a2e8a3a547e18aef32d7c1252113eb839451f')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@@ -44,6 +45,7 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
_mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
prepare() {
+ mkdir mozbuild
cd mozilla-unified
# actual appmenu patch from ubuntu repos
@@ -57,7 +59,6 @@ ac_add_options --enable-application=browser
ac_add_options --prefix=/usr
ac_add_options --enable-release
-ac_add_options --enable-linker=gold
ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
@@ -75,15 +76,15 @@ ac_add_options --with-google-api-keyfile=${PWD@Q}/google-api-key
ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key
# System libraries
-ac_add_options --with-system-zlib
+ac_add_options --enable-system-ffi
+ac_add_options --enable-system-sqlite
ac_add_options --with-system-bz2
ac_add_options --with-system-icu
ac_add_options --with-system-jpeg
ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
-ac_add_options --enable-system-sqlite
-ac_add_options --enable-system-ffi
+ac_add_options --with-system-zlib
# Features
ac_add_options --enable-alsa
@@ -99,6 +100,8 @@ build() {
cd mozilla-unified
export MOZ_SOURCE_REPO="$_repo"
+ export MOZ_NOSPAM=1
+ export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
./mach build
./mach buildsymbols