summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornikatar2020-07-01 00:06:53 +0300
committernikatar2020-07-01 00:06:53 +0300
commitcc4f4a5e1bd0e7a3cbcf9f6f241b9d2d001bee88 (patch)
tree23235d588239e579de03f70af81f937ec3bab4db /PKGBUILD
parenta7e9dab48959bd8fbbac46f9fc92b2dfd7b3f203 (diff)
downloadaur-cc4f4a5e1bd0e7a3cbcf9f6f241b9d2d001bee88.tar.gz
78.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 20 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86bc1fcaf9df..80a760377c3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,34 +7,31 @@
pkgname=firefox-appmenu
_pkgname=firefox
-pkgver=77.0.1
+pkgver=78.0
pkgrel=1
pkgdesc="Firefox from extra with appmenu patch"
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
-depends=(gtk3 libxt startup-notification mime-types dbus-glib ffmpeg nss
- ttf-font libpulse)
-makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
- xorg-server-xvfb autoconf2.13 rust clang llvm jack gtk2 python
- nodejs python2-psutil cbindgen nasm)
+depends=(gtk3 libxt mime-types dbus-glib ffmpeg nss ttf-font libpulse)
+makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
+ autoconf2.13 rust clang llvm jack gtk2 nodejs cbindgen nasm
+ python-setuptools python-psutil)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech'
'hunspell-en_US: Spell checking, American English')
-provides=("firefox=$pkgver")
-conflict=("firefox")
options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
0001-Use-remoting-name-for-GDK-application-names.patch
$_pkgname.desktop
unity-menubar.patch)
-sha256sums=('54256fc5f8e9c2e8129ef84773fae31fcfdaf95da6d4d03151f3939e9f749640'
+sha256sums=('291a593151e476e6c4b61e48a3bdd5a11896fbde6261dcad347d5b7df265a058'
'SKIP'
'3bb7463471fb43b2163a705a79a13a3003d70fff4bbe44f467807ca056de9a75'
'34514a657d6907a159594c51e674eeb81297c431ec26a736417c2fdb995c2c0c'
- 'c87e9df0fa2ba96989b70403e412aae54de9e29a56c7872f155cfd8a1e0b9a33')
+ '411f1580801f7b1484575d38f5967cf3d8c68efbba8dd4e2950e13a763bd09d8')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -52,12 +49,12 @@ _mozilla_api_key=e05d56db0a694edc8b5aaebda3f2db6a
prepare() {
mkdir mozbuild
cd firefox-$pkgver
-
+
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
-
+
# actual appmenu patch from ubuntu repos
- # http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_77.0.1+build1-0ubuntu0.18.04.1.debian.tar.xz
+ # https://launchpad.net/~mozillateam/+archive/ubuntu/firefox-next/+sourcefiles/firefox/78.0+build2-0ubuntu0.18.04.1~mt1/firefox_78.0+build2-0ubuntu0.18.04.1~mt1.debian.tar.xz
patch -Np1 -i ../unity-menubar.patch
echo -n "$_google_api_key" >google-api-key
@@ -93,12 +90,14 @@ ac_add_options --with-google-location-service-api-keyfile=${PWD@Q}/google-api-ke
ac_add_options --with-google-safebrowsing-api-keyfile=${PWD@Q}/google-api-key
ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key
+# System libraries
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+
# Features
ac_add_options --enable-alsa
ac_add_options --enable-jack
-ac_add_options --enable-startup-notification
ac_add_options --enable-crashreporter
-ac_add_options --disable-gconf
ac_add_options --disable-updater
ac_add_options --disable-tests
END
@@ -162,7 +161,7 @@ package() {
cd firefox-$pkgver
DESTDIR="$pkgdir" ./mach install
- local vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
+ local vendorjs="$pkgdir/usr/lib/$_pkgname/browser/defaults/preferences/vendor.js"
install -Dvm644 /dev/stdin "$vendorjs" <<END
// Use LANG environment variable to choose locale
pref("intl.locale.requested", "");
@@ -177,7 +176,7 @@ pref("browser.shell.checkDefaultBrowser", false);
pref("extensions.autoDisableScopes", 11);
END
- local distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
+ local distini="$pkgdir/usr/lib/$_pkgname/distribution/distribution.ini"
install -Dvm644 /dev/stdin "$distini" <<END
[Global]
id=archlinux
@@ -213,10 +212,10 @@ END
# Replace duplicate binary with wrapper
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -srfv "$pkgdir/usr/bin/$pkgname" "$pkgdir/usr/lib/$pkgname/firefox-bin"
+ ln -srfv "$pkgdir/usr/bin/$_pkgname" "$pkgdir/usr/lib/$_pkgname/firefox-bin"
# Use system certificates
- local nssckbi="$pkgdir/usr/lib/$pkgname/libnssckbi.so"
+ local nssckbi="$pkgdir/usr/lib/$_pkgname/libnssckbi.so"
if [[ -e $nssckbi ]]; then
ln -srfv "$pkgdir/usr/lib/libnssckbi.so" "$nssckbi"
fi
@@ -229,3 +228,5 @@ END
cp -fvt "$startdir" {} +
fi
}
+
+# vim:set sw=2 et: