summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornikatar2020-05-03 02:50:01 +0300
committernikatar2020-05-03 02:50:01 +0300
commite77d129498066ce0ea896fbd1b00bff6d4cbe232 (patch)
treed035fdb95fe0bf5319c8a5d5e4dec985799bd295 /PKGBUILD
parent51c30f1af27a32ed1f2e6040a6488637e6e8bdec (diff)
downloadaur-e77d129498066ce0ea896fbd1b00bff6d4cbe232.tar.gz
75.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28800408bb7c..3f00d6256299 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,14 @@
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
-# Additional patching: Nikita Tarasov <nikatar@disroot.org>
+
+### Appmenu patching ###
+# PKGBUILD: Nikita Tarasov <nikatar@disroot.org>
pkgname=firefox-appmenu
_pkgname=firefox
pkgver=75.0
-pkgrel=1
+pkgrel=2
pkgdesc="Firefox from extra with appmenu patch"
arch=(x86_64)
license=(MPL GPL LGPL)
@@ -25,13 +27,15 @@ provides=("firefox=$pkgver")
conflict=("firefox")
options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
+ 0001-Bug-1623885-Add-subsystem-to-Mesa-sandbox-policy-to-.patch
0001-Use-remoting-name-for-GDK-application-names.patch
$_pkgname.desktop
unity-menubar.patch)
sha256sums=('bbb1054d8f2717c634480556d3753a8483986af7360e023bb6232df80b746b0f'
'SKIP'
+ 'ebb169804750ddc10a4801ed6ddb37356331bbf76615f58eb29de2e6e15ee930'
'5f7ac724a5c5afd9322b1e59006f4170ea5354ca1e0e60dab08b7784c2d8463c'
- 'e466789015e15be9409b7a7044353674ca6aa0f392e882217f90c79821fe2630'
+ '34514a657d6907a159594c51e674eeb81297c431ec26a736417c2fdb995c2c0c'
'364e5c59a5a55d0be43bcb090dec51476580d0c35b63c0974a25bfeba212a1fc')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@@ -50,11 +54,15 @@ _mozilla_api_key=e05d56db0a694edc8b5aaebda3f2db6a
prepare() {
mkdir mozbuild
cd firefox-$pkgver
+
+ # https://bugs.archlinux.org/task/66185
+ patch -Np1 -i ../0001-Bug-1623885-Add-subsystem-to-Mesa-sandbox-policy-to-.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
# actual appmenu patch from ubuntu repos
+ # http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_75.0+build3-0ubuntu0.18.04.1.debian.tar.xz
patch -Np1 -i ../unity-menubar.patch
echo -n "$_google_api_key" >google-api-key