summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel M. Capella2018-03-13 18:02:08 -0400
committerDaniel M. Capella2018-03-13 18:02:08 -0400
commit52cb7120e48ca62ba2b40e3d5d563e02d92a8b94 (patch)
tree8a5dc9d98b598c91625aca8212c0470a5c6cf9b1 /PKGBUILD
downloadaur-52cb7120e48ca62ba2b40e3d5d563e02d92a8b94.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01c152de49b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Daniel M. Capella <polycitizen@gmail.com>
+
+pkgname=firefox-auto-tab-discard
+pkgver=0.1.8
+pkgrel=1
+pkgdesc='Use native tab discard method to automatically reduce memory usage of inactive tab'
+url=https://add0n.com/tab-discard.html
+arch=('any')
+license=('MPL2')
+groups=('firefox-addons')
+source=("https://addons.cdn.mozilla.net/user-media/addons/909373/auto_tab_discard-$pkgver-an+fx.xpi")
+noextract=("${source##*/}")
+sha256sums=('3392264df6082e44d8edd6cfe2ebd71049cc5d4020ab25109a34d284f68813e5')
+
+package() {
+ install -Dm644 "${source##*/}" "$pkgdir"/usr/lib/firefox/browser/extensions/{c2c003ee-bd69-42a2-b0e9-6f34222cb046}.xpi
+}
+
+# vim:set ts=2 sw=2 et: