summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYour Name2018-03-14 17:45:26 -0400
committerYour Name2018-03-14 17:45:26 -0400
commit3937b97c3aaf637aa7b53d526e88885f15d2982f (patch)
treeb3e75c7f36f9e23ece46f9d8a26d586bac2abc39 /PKGBUILD
parentc9668b2519569cf4b323a36c79780fea639e0479 (diff)
downloadaur-3937b97c3aaf637aa7b53d526e88885f15d2982f.tar.gz
63
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d5a340c5ddb..561557c39a6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,10 @@
pkgname=firefox-beta
name=firefox-beta
-pkgver=60.0.1
+pkgver=60.0.3
pkgrel=1
-meme=DEVEDITION_60_0b1_RELEASE
+meme=FIREFOX_60_0b3_RELEASE
+meme2=DEVEDITION_60_0b3_RELEASE
pkgdesc="Standalone web browser from mozilla.org, with telemetry and signing disabled"
arch=(i686 x86_64)
license=(MPL GPL LGPL)
@@ -21,7 +22,7 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech')
options=(!emptydirs !makeflags !strip)
-source=("https://hg.mozilla.org/mozilla-unified/archive/$meme.tar.gz"
+source=("https://hg.mozilla.org/mozilla-unified/archive/$meme2.tar.gz"
https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/$name.desktop
https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-symbolic.svg
https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-52-disable-data-sharing-infobar.patch
@@ -59,7 +60,7 @@ prepare() {
mkdir path
ln -s /usr/bin/python2 path/python
- cd mozilla-unified-$meme
+ cd mozilla-unified-$meme2
patch -Np1 -i ../id.patch
@@ -128,7 +129,7 @@ END
}
build() {
- cd mozilla-unified-$meme
+ cd mozilla-unified-$meme2
# _FORTIFY_SOURCE causes configure failures
CPPFLAGS+=" -O2"
@@ -144,7 +145,7 @@ build() {
}
package() {
- cd mozilla-unified-$meme
+ cd mozilla-unified-$meme2
DESTDIR="$pkgdir" ./mach install
find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +