summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIván Ruvalcaba2017-08-30 22:49:46 -0500
committerIván Ruvalcaba2017-08-30 22:49:46 -0500
commite838f40f3752b62a26de7ee324683e5e2a8302f1 (patch)
treea7f9f3b8687e84a09fb8b86e2692a1cd006c463f /PKGBUILD
parente429e12cbac6e9f56309cd28b82e15c5c35abd79 (diff)
downloadaur-e838f40f3752b62a26de7ee324683e5e2a8302f1.tar.gz
Update package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 21 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 579e012eb3f7..fefb5d19673e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,34 +9,40 @@
_name=firefox
_channel=developer
_lang=es-MX
+_codename=date
pkgname="${_name}-${_channel}-${_lang,,}"
pkgdesc="Standalone web browser from mozilla.org, developer build (${_lang})"
url="http://www.mozilla.org/projects/firefox"
-pkgver=54.0a2.20170307
-_version=54.0a2
+pkgver=56.0b7.20170830
+_version=56.0b7
pkgrel=1
arch=('i686' 'x86_64')
conflicts=('firefox-developer')
license=('MPL' 'GPL' 'LGPL')
-_file="${_name}-${_version}.en-US.linux"
-_file_l10n="${_name}-${_version}.${_lang}.linux"
-_srcurl="https://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-aurora"
-_srcurl_l10n="${_srcurl}-l10n"
+_srcurl="https://download-installer.cdn.mozilla.net/pub/devedition/releases"
source=(
- 'firefox-developer.desktop' 'vendor.js'
- "${_srcurl_l10n}/${_file_l10n}-${CARCH}.tar.bz2"
- "${_srcurl}/${_file}-${CARCH}.txt")
+ 'firefox-developer.desktop'
+ 'vendor.js'
+ "${_srcurl}/${_version}/linux-${CARCH}/${_lang}/${_name}-${_version}.tar.bz2")
sha512sums=(
'018c9995046572ed85bd8b6b569ed5dfd3fdfeec3ca25d013879ce1fd6faac13362d2c1554af3351e9ed672e316f7e6c4130760b48c973e65ef37abaf44f7864'
'bae5a952d9b92e7a0ccc82f2caac3578e0368ea6676f0a4bc69d3ce276ef4f70802888f882dda53f9eb8e52911fb31e09ef497188bcd630762e1c0f5293cc010'
- 'SKIP'
- 'SKIP')
+ 'a9702aff50e7d30e770f4331c9d529a68a04103fd03130ecbc520f01eeeff391b49e708b0adb6a4c20e09f9ef08090d7662cb46536ea8adec9edc2774901561b')
+depends=('dbus-glib' 'gtk3' 'libxt' 'nss' 'mime-types')
+optdepends=('pulseaudio: audio support'
+ 'ffmpeg: h.264 video'
+ 'gtk2: flash plugin support'
+ 'hunspell: spell checking'
+ 'hyphen: hyphenation'
+ 'libnotify: notification integration'
+ 'networkmanager: location detection via available WiFi networks'
+ 'speech-dispatcher: text-to-speech'
+ 'startup-notification: support for FreeDesktop Startup Notification')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353')
-depends=('alsa-lib' 'libxt' 'libnotify' 'mime-types' 'nss' 'gtk2' 'gtk3'
- 'sqlite' 'dbus-glib')
-pkgver() {
- echo "${_version}.$(head -n1 "${srcdir}/${_file}-${CARCH}.txt" | cut -c-8)"
+prepare() {
+ # remove the dictionaries included in the archive
+ rm -rf firefox/dictionaries
}
package() {