summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2020-07-29 22:48:08 +0200
committerJoan Figueras2020-07-29 22:48:08 +0200
commit4fe367e4a5eb7d9a6f29f558b48a7f611d65f5d3 (patch)
tree3bae9f6d06ccccb9fcbdb4ef9f1553b2e05612ba /PKGBUILD
parent5aecad84bcb3cba3077977a9af1afbfdfe710826 (diff)
downloadaur-4fe367e4a5eb7d9a6f29f558b48a7f611d65f5d3.tar.gz
78.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae1333803b2c..655c27ab7e70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=firefox-esr
-pkgver=78.0.2
+pkgver=78.1.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org, Extended Support Release"
arch=(x86_64)
@@ -12,7 +12,7 @@ url="https://www.mozilla.org/en-US/firefox/organizations/"
depends=(gtk3 libxt mime-types dbus-glib ffmpeg nss ttf-font libpulse)
makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
autoconf2.13 rust clang llvm jack gtk2 nodejs cbindgen nasm
- python-setuptools python-psutil)
+ python-setuptools python-psutil lld)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@@ -22,12 +22,14 @@ provides=(firefox=${pkgver})
conflicts=(firefox)
options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.xz{,.asc}
- ${pkgname}.desktop 0001-Use-remoting-name-for-GDK-application-names.patch upload-symbol-archive)
-sha256sums=('e0b5596644d4f9cb7c3231f66a982e4a6729ff8f36c14245f1ccfdf8c1c79a0a'
+ ${pkgname}.desktop 0001-Use-remoting-name-for-GDK-application-names.patch upload-symbol-archive
+ rust-145.patch::https://hg.mozilla.org/integration/autoland/raw-rev/e5d2a6d5187b)
+sha256sums=('3600a396d9312c5e9f637b267926ca4771d84a56b26b960cc7d72e98683b64a2'
'SKIP'
'd86fe1636346ff003744b65e73cd3a7182618faedf3ee57023bb942e325cc726'
'3bb7463471fb43b2163a705a79a13a3003d70fff4bbe44f467807ca056de9a75'
- 'eb9b9c058d1505e5b82526a8cad63f98e04fc17c4715f6b4cfc778e10fcfaf27')
+ 'eb9b9c058d1505e5b82526a8cad63f98e04fc17c4715f6b4cfc778e10fcfaf27'
+ 'afc0a66777dc38d8b697b0eeacdf7a723b2e324ce5864a9c79b8b2eb83e27388')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -43,12 +45,16 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
_mozilla_api_key=e05d56db0a694edc8b5aaebda3f2db6a
prepare() {
- mkdir mozbuild
+ mkdir -p mozbuild
cd firefox-$pkgver
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1654465
+ patch -Np1 -i ../rust-145.patch || true
+ sed -e 's/1.31.0/1.38.0/' -i build/moz.configure/rust.configure
+
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
@@ -60,6 +66,8 @@ ac_add_options --enable-release
ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
+ac_add_options --enable-linker=lld
+ac_add_options --disable-elf-hack
export CC='clang --target=x86_64-unknown-linux-gnu'
export CXX='clang++ --target=x86_64-unknown-linux-gnu'
export AR=llvm-ar
@@ -123,15 +131,11 @@ END
xvfb-run -s "-screen 0 1920x1080x24 -nolisten local" \
./mach python build/pgo/profileserver.py
- if [[ ! -s merged.profdata ]]; then
- echo "No profile data produced."
- return 1
- fi
+ stat -c "Profile data found (%s bytes)" merged.profdata
+ test -s merged.profdata
- if [[ ! -s jarlog ]]; then
- echo "No jar log produced."
- return 1
- fi
+ stat -c "Jar log found (%s bytes)" jarlog
+ test -s jarlog
echo "Removing instrumented browser..."
./mach clobber