summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2021-02-14 03:07:47 +0100
committerJoan Figueras2021-02-14 03:07:47 +0100
commit5d104edb95c9f0f89e9b7e1d4dfcd37bc73a73fa (patch)
tree7f3098a048ca5c177fc89185f82267eea275147a /PKGBUILD
parent5142a988bc6055108bc542ac14a2d528802863f3 (diff)
downloadaur-5d104edb95c9f0f89e9b7e1d4dfcd37bc73a73fa.tar.gz
Fixed build with Rust 1.50
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a796105f155d..1bf01920c7af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firefox-esr
pkgver=78.7.1
-pkgrel=1
+pkgrel=2
pkgdesc="Standalone web browser from mozilla.org, Extended Support Release"
arch=(x86_64)
license=(MPL GPL LGPL)
@@ -23,13 +23,15 @@ conflicts=(firefox)
options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.xz{,.asc}
${pkgname}.desktop 0001-Use-remoting-name-for-GDK-application-names.patch upload-symbol-archive
- rust_1.48.patch.gz)
+ rust_1.48.patch.gz
+ rust_1.50.patch)
sha256sums=('5042783e2cf94d21dd990d2083800f05bc32f8ba65532a715c7be3cb7716b837'
'SKIP'
'd86fe1636346ff003744b65e73cd3a7182618faedf3ee57023bb942e325cc726'
'3bb7463471fb43b2163a705a79a13a3003d70fff4bbe44f467807ca056de9a75'
'eb9b9c058d1505e5b82526a8cad63f98e04fc17c4715f6b4cfc778e10fcfaf27'
- 'd32c87c4526e897d64453914da43f99366d1d0b7d71e43b4027a6cb5aa274040')
+ 'd32c87c4526e897d64453914da43f99366d1d0b7d71e43b4027a6cb5aa274040'
+ 'ed71ddae4ae4115e5d78ef2d6291bfe20f02198273746081d8c89f24919a1ba7')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -54,6 +56,9 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1667736
patch -Np1 -i ../rust_1.48.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1684261
+ patch -Np1 -i ../rust_1.50.patch
+
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key