summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFigue2017-03-07 00:55:10 +0100
committerFigue2017-03-07 00:55:10 +0100
commitf051e7b45d60775079c25d83c8e73ab1b68edb51 (patch)
tree5fc3ff462b7e1c07e24268beb895fac672010356 /PKGBUILD
parent527c3b44854590b4172128842cb6a662d842fcbe (diff)
downloadaur-f051e7b45d60775079c25d83c8e73ab1b68edb51.tar.gz
Update to 52.0esr
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD157
1 files changed, 109 insertions, 48 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 613f465495ad..f4fe0060e8ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,36 @@
-# $Id: PKGBUILD 239402 2015-05-15 12:36:25Z foutrelis $
+# $Id$
# Maintainer : Figue <ffigue@gmail.com>
# Contributor : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor : Ionut Biru <ibiru@archlinux.org>
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=firefox-esr
-pkgver=45.7.0
+pkgver=52.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org, Extended Support Release"
-arch=('i686' 'x86_64')
-license=('MPL' 'GPL' 'LGPL')
+arch=(i686 x86_64)
+license=(MPL GPL LGPL)
url="https://www.mozilla.org/en-US/firefox/organizations/"
-depends=('gtk3' 'gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types'
- 'dbus-glib' 'alsa-lib' 'ffmpeg' 'libvpx' 'libevent' 'nss' 'hunspell'
- 'sqlite' 'ttf-font' 'icu')
-makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'imake' 'gconf'
- 'libpulse' 'inetutils' 'xorg-server-xvfb' 'autoconf2.13')
+depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
+ libvpx libevent nss hunspell sqlite ttf-font icu)
+makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb
+ autoconf2.13 cargo)
optdepends=('networkmanager: Location detection via available WiFi networks'
- 'upower: Battery API')
+ 'libnotify: Notification integration'
+ 'upower: Battery API'
+ 'speech-dispatcher: Text-to-Speech')
provides=(firefox)
conflicts=(firefox)
options=('!emptydirs' '!makeflags')
source=(https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.xz
- mozconfig firefox.desktop firefox-install-dir.patch vendor.js
- mozilla-1245076-1.patch
- no-libnotify.patch
- harfbuzz-1.1.3-fixed.patch.gz)
-sha256sums=('4b5610691d32b77dd0dec25902f0d19e530c184cedc11babb530621cbdd33143'
- '21ef71942681206c650862215543f35fd0ceaed362d93d6f9c30f7a24fb204b4'
+ firefox.desktop firefox-symbolic.svg
+ firefox-install-dir.patch rust-i686.patch fix-wifi-scanner.diff)
+sha256sums=('40748a6d73ecea29257c1b4bdbb8d218c35bf98bef380173c780e922132506de'
'c202e5e18da1eeddd2e1d81cb3436813f11e44585ca7357c4c5f1bddd4bec826'
+ 'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
- '4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
- '6e7cba25c52b246da183b8309e7b56208bd991d1a7adb40063c5702a6f3722ea'
- 'e4ebdd14096d177d264a7993dbd5df46463605ff45f783732c26d30b9caa53a7'
- '899c19ee98b0eab3d98383d70220ab26c912eeec8b04c8dd37f05d0ab389e574')
+ 'f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269'
+ '9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8')
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -42,35 +39,75 @@ validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
# more information.
_google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
+# Mozilla API keys (see https://location.services.mozilla.com/api)
+# Note: These are for Arch Linux use ONLY. For your own distribution, please
+# get your own set of keys. Feel free to contact heftig@archlinux.org for
+# more information.
+_mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
+
+
prepare() {
+ mkdir path
+ ln -s /usr/bin/python2 path/python
+
cd firefox-${pkgver}esr
- cp ../mozconfig .mozconfig
patch -Np1 -i ../firefox-install-dir.patch
- # GCC 6
- patch -Np1 -i ../mozilla-1245076-1.patch
-
- # Notifications with libnotify are broken
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1236150
- patch -Np1 -i ../no-libnotify.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
+ patch -Np1 -i ../fix-wifi-scanner.diff
- # Harfbuzz patch to v1.1.3
- patch -Np1 -i ../harfbuzz-1.1.3-fixed.patch
+ # Build with the rust targets we actually ship
+ patch -Np1 -i ../rust-i686.patch
echo -n "$_google_api_key" >google-api-key
- echo "ac_add_options --with-google-api-keyfile=\"$PWD/google-api-key\"" >>.mozconfig
-
- mkdir "$srcdir/path"
- ln -s /usr/bin/python2 "$srcdir/path/python"
-
+ echo -n "$_mozilla_api_key" >mozilla-api-key
+
+ cat >.mozconfig <<END
+ac_add_options --enable-application=browser
+
+ac_add_options --prefix=/usr
+ac_add_options --enable-release
+ac_add_options --enable-gold
+ac_add_options --enable-pie
+ac_add_options --enable-rust
+
+# Branding
+ac_add_options --enable-official-branding
+ac_add_options --enable-update-channel=release
+export MOZ_ADDON_SIGNING=1
+export MOZ_REQUIRE_SIGNING=1
+
+# Keys
+ac_add_options --with-google-api-keyfile=${PWD@Q}/google-api-key
+ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key
+
+# System libraries
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+ac_add_options --with-system-icu
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-system-bz2
+ac_add_options --with-system-libevent
+ac_add_options --with-system-libvpx
+ac_add_options --enable-system-hunspell
+ac_add_options --enable-system-sqlite
+ac_add_options --enable-system-ffi
+ac_add_options --enable-system-pixman
+
+# Features
+ac_add_options --enable-startup-notification
+ac_add_options --disable-crashreporter
+ac_add_options --disable-updater
+
+STRIP_FLAGS="--strip-debug"
+END
}
build() {
cd firefox-${pkgver}esr
- export PATH="$srcdir/path:$PATH"
-
# _FORTIFY_SOURCE causes configure failures
CPPFLAGS+=" -O2"
@@ -78,12 +115,13 @@ build() {
LDFLAGS+=" -Wl,-z,now"
# GCC 6
- CFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
- CXXFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
+ CXXFLAGS+=" -fno-delete-null-pointer-checks -fno-schedule-insns2"
+
+ export PATH="$srcdir/path:$PATH"
# Do PGO
-# xvfb-run -a -s "-extension GLX -screen 0 1280x1024x24" \
-# make -f client.mk build MOZ_PGO=1
+ #xvfb-run -a -n 95 -s "-extension GLX -screen 0 1280x1024x24" \
+ # make -f client.mk build MOZ_PGO=1
make -f client.mk build
}
@@ -91,11 +129,25 @@ package() {
cd firefox-${pkgver}esr
make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
- install -Dm644 ../vendor.js "$pkgdir/usr/lib/firefox-esr/browser/defaults/preferences/vendor.js"
+ _vendorjs="$pkgdir/usr/lib/firefox/browser/defaults/preferences/vendor.js"
+ install -Dm644 /dev/stdin "$_vendorjs" <<END
+// Use LANG environment variable to choose locale
+pref("intl.locale.matchOS", true);
+
+// Disable default browser checking.
+pref("browser.shell.checkDefaultBrowser", false);
+
+// Don't disable our bundled extensions in the application directory
+pref("extensions.autoDisableScopes", 11);
+pref("extensions.shownSelectionUI", true);
+
+// Opt all of us into e10s, instead of just 50%
+pref("browser.tabs.remote.autostart", true);
+END
for i in 16 22 24 32 48 256; do
- install -Dm644 browser/branding/official/default$i.png \
- "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png"
+ install -Dm644 browser/branding/official/default$i.png \
+ "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png"
done
install -Dm644 browser/branding/official/content/icon64.png \
"$pkgdir/usr/share/icons/hicolor/64x64/apps/firefox.png"
@@ -105,16 +157,25 @@ package() {
"$pkgdir/usr/share/icons/hicolor/192x192/apps/firefox.png"
install -Dm644 browser/branding/official/content/about-logo@2x.png \
"$pkgdir/usr/share/icons/hicolor/384x384/apps/firefox.png"
+ install -Dm644 ../firefox-symbolic.svg \
+ "$pkgdir/usr/share/icons/hicolor/symbolic/apps/firefox-symbolic.svg"
install -Dm644 ../firefox.desktop \
"$pkgdir/usr/share/applications/firefox.desktop"
# Use system-provided dictionaries
- rm -rf "$pkgdir"/usr/lib/firefox/{dictionaries,hyphenation}
- ln -s /usr/share/hunspell "$pkgdir/usr/lib/firefox/dictionaries"
- ln -s /usr/share/hyphen "$pkgdir/usr/lib/firefox/hyphenation"
+ rm -r "$pkgdir"/usr/lib/firefox/dictionaries
+ ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/firefox/dictionaries"
+ ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/firefox/hyphenation"
+
+ # Install a wrapper to avoid confusion about binary path
+ install -Dm755 /dev/stdin "$pkgdir/usr/bin/firefox" <<END
+#!/bin/sh
+exec /usr/lib/firefox/firefox "\$@"
+END
- # Replace duplicate binary with symlink
+ # Replace duplicate binary with wrapper
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -sf firefox "$pkgdir/usr/lib/firefox/firefox-bin"
+ ln -srf "$pkgdir/usr/bin/firefox" \
+ "$pkgdir/usr/lib/firefox/firefox-bin"
}