summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorw2018-07-26 10:42:23 +0200
committerw2018-07-26 10:42:23 +0200
commit4c4b4645c78488abd6692f782081f1a35fc46489 (patch)
tree6552e7ee2c4a628388c25539449a11d142d0991d /PKGBUILD
parentb62a0791338d117c8d0de52b418bc6f348c43e10 (diff)
downloadaur-4c4b4645c78488abd6692f782081f1a35fc46489.tar.gz
Update to version 60.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD90
1 files changed, 42 insertions, 48 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b3498a53d0a..c7e5c1330e2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,96 +1,86 @@
# firefox-esr-privacy
pkgname=firefox-esr-privacy
-_basever=52
-pkgver=52.5.0
+_basever=60
+pkgver=60.1.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
url="https://www.mozilla.org/firefox/"
depends=('autoconf2.13' 'gtk2' 'libxt' 'startup-notification' 'dbus-glib' 'alsa-lib' 'desktop-file-utils'
- 'hicolor-icon-theme' 'libvpx' 'icu' 'libevent' 'nss' 'hunspell' 'sqlite')
-makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'xorg-server' 'inetutils')
+ 'hicolor-icon-theme' 'libvpx' 'icu' 'libevent' 'nss' 'hunspell' 'sqlite' 'apulse')
+makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'xorg-server' 'inetutils' 'rust' 'patchelf' 'pulseaudio')
install=firefox.install
options=('!emptydirs')
conflicts=('firefox')
provides=('firefox')
source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.xz
- firefox-install-dir.patch
+ firefox-${_basever}-disable-data-sharing-infobar.patch
firefox-${_basever}-disable-location.services.mozilla.com.patch
firefox-${_basever}-disable-pocket-leftovers.patch
- firefox-${_basever}-disable-sponsored-tiles.patch
- firefox-${_basever}-prefs.patch
- firefox-${_basever}-disable-telemetry.patch
- firefox-${_basever}-disable-data-sharing-infobar.patch
+ firefox-${_basever}-disable-newtab-page-remote.patch
firefox-${_basever}-disable-reader.patch
+ firefox-${_basever}-disable-telemetry.patch
+ firefox-${_basever}-prefs.patch
+ firefox-${_basever}-disable-first-run-privacy-policy.patch
firefox.desktop
- firefox-fixed-loading-icon.png
mozconfig)
-sha256sums=('0e583576f6bbdc9d863656c43b8c97a60f276725bca20459b7511e2afacac85f'
- 'b7a9eb7f4c9f5c297978459338d389e5bc790e5c5d89805668f7d24ea1d485b2'
- '8d9afa1f940a9dac689ead40a57990d1491f34a1787b2222f8f5b5e485d54103'
- 'd6760634e4926ce5ad0df501d06139a5e693d7058e671a195c9e0b54197c1d96'
- 'a72c657784dc5804509456d9ba39ccc8d5e5998c847f49abbcfeb2a547290815'
- '80d6181d11c200aca2781f69ffeafb59ea23952304d161c2812a2f5a98b273b0'
- 'b661dcaa00323119e58a3b9d5b6e732291a107fbd29d242fb1ddcd36ea50106e'
- '52a94f48e562f98ba0b22b43b1684f6a813872b9c310d6f7567fe91aaab4944b'
- '7f171b7d69866ac6d8945ab0867b2646964362c791875c6428b4c2c8e3f3fb5b'
+sha256sums=('a4e7bb80e7ebab19769b2b8940966349136a99aabd497034662cffa54ea30e40'
+ 'd8377a0f225df1e334bf82845ba082f499af561311c7033b61084b24c720924f'
+ '05da47c8e2b5271f1979b7f5c15941b50645e68d31b556fcc8ab381699c979f5'
+ '22f8a6e42617bc733e0627513dd58dbaa4a924a725db00ad7b2b666425d7edd2'
+ 'f5f58edd11e004cbbd3504bcc531b6259ecd4a67b45e0656dda70f08ef290d7f'
+ 'ce583b1e164f62d4869e97e46c724ea946f605733f0f2b1919162ca58b97883d'
+ 'adc25bf1a8712ce1a3aa91afa7ddbb8df805671f462089f67ae16adc5c3390a5'
+ '57ea308737c2d82fff6b8ad55ceeed445018c6fd482efd14b2026312e8485b6c'
+ '3c8008f7d0d0a2fcafcdc24f9a838bc72306d452f1dce233a65fcf0eba3d4e0f'
'0bcfe168964338ec9c6e781479f2f8d06aa44f2262d6405ff8fa42983be89630'
- '68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213'
- 'c4329549076a3cce493a5053e4bd84d088b04713021c6ebbae0ab68a02de3d8c')
+ 'c3d0a8c25d1122b20151fe085a8d5bc79234ae3dc05a606855eb68cfb7817d2c')
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
prepare() {
- cd firefox-${pkgver}esr
+ #cd firefox-${pkgver}esr
+ cd firefox-${pkgver}
cp "$srcdir"/mozconfig mozconfig
-
- # Disable sponsored tiles
- # This patch is not needed anymore, it also breaks the newtab page (nothing on it) and restore closed tabs does not work anymore
- # patch -Np1 -i "$srcdir"/firefox-${_basever}-disable-sponsored-tiles.patch
-
+
# Disable Pocket integration leftovers
patch -Np1 -i "$srcdir"/firefox-${_basever}-disable-pocket-leftovers.patch
# Remove pocket source directory
rm -fr browser/extensions/pocket
+ # Disable pocket on the new tab page and disable remote fetching of top sites
+ patch -Np1 -i "$srcdir"/firefox-${_basever}-disable-newtab-page-remote.patch
# Disable geo IP lookup on first run
patch -Np1 -i "$srcdir"/firefox-${_basever}-disable-location.services.mozilla.com.patch
-
+
# Set some sensible defaults
patch -Np1 -i "$srcdir"/firefox-${_basever}-prefs.patch
-
+
# Disable telemetry options
patch -Np1 -i "$srcdir"/firefox-${_basever}-disable-telemetry.patch
-
+
# Disable infobar "Firefox automatically sends some data to Mozilla..."
patch -Np1 -i "$srcdir"/firefox-${_basever}-disable-data-sharing-infobar.patch
-
+
# Disable reader view
patch -Np1 -i "$srcdir"/firefox-${_basever}-disable-reader.patch
-
- # Fix build with Fontconfig 2.6
- sed -i '/^ftcache.h/a ftfntfmt.h' config/system-headers
-
- # Fix tab loading icon not working with libpng 1.6
- cp "$srcdir"/firefox-fixed-loading-icon.png browser/themes/linux/tabbrowser/loading.png
-
- # Install in /usr/lib/firefox without version number
- patch -Np1 -i "$srcdir"/firefox-install-dir.patch
+
+ # Disable privacy policy new tab on first run
+ patch -Np1 -i "$srcdir"/firefox-${_basever}-disable-first-run-privacy-policy.patch
}
build() {
- cd firefox-${pkgver}esr
-
- # Fix configure: error: Your toolchain does not support C++0x/C++11 mode properly. Please upgrade your toolchain
- unset CPPFLAGS
-
- make -f client.mk
+ #cd firefox-${pkgver}esr
+ cd firefox-${pkgver}
+
+ ./mach build
}
package() {
- cd firefox-${pkgver}esr
- make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
+ #cd firefox-${pkgver}esr
+ cd firefox-${pkgver}
+ DESTDIR="$pkgdir" ./mach install
install -Dm644 "$srcdir"/firefox.desktop "$pkgdir/usr/share/applications/firefox.desktop"
@@ -98,4 +88,8 @@ package() {
rm -rf "$pkgdir"/usr/lib/firefox/{dictionaries,hyphenation}
ln -s /usr/share/hunspell "$pkgdir/usr/lib/firefox/dictionaries"
ln -s /usr/share/hyphen "$pkgdir/usr/lib/firefox/hyphenation"
+
+ # Firefox no longer support Alsa, it crashes frequently with Alsa on FF>=60
+ # Use apulse (PulseAudio emulation for Alsa) but don't require a user to run "apulse firefox" everytime by changing the rpath
+ patchelf --set-rpath /usr/lib/apulse "$pkgdir/usr/lib/firefox/libxul.so"
}