summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-04-22 11:41:24 +0200
committerXZS2016-04-22 11:41:24 +0200
commit5ac4d704b7835f5566ee5e7b15e2747bbb22361f (patch)
tree315852081bccfb52d53e2bd398ba893aac2ce837 /PKGBUILD
parent4dff45f03a8579f5654a812b3521ff1822f6c63b (diff)
downloadaur-5ac4d704b7835f5566ee5e7b15e2747bbb22361f.tar.gz
exclude hidden filed in subdirectories
Despite the wild card * not coping hidden files, this does not exclude such in subdirectories. A reliable method to exclude files by a pattern like "starting with a dot" would be rsync. But to not pull it in as an additional dependency, copy and find are preferred.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fc3cd236517..28c469f78e23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -79,8 +79,8 @@ depends=(${pkgname%%-*})
package() {
compose_dependencies
prepare_target
- install -d "$destdir/$id"
- cp --no-preserve=ownership,mode -r * "$destdir/$id"
+ cp --no-preserve=ownership,mode -r . "$destdir/$id"
+ find "$destdir/$id" -mindepth 1 -name ".*" -exec rm -rf '{}' +
}
# Hidden from mksrcinfo in silly subfunction.