summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-09-22 01:28:54 +0200
committerXZS2016-09-22 01:28:54 +0200
commitdfdf2a838f985c0bb03f18d04a2e7b67df320f5d (patch)
treec0d947d7f341c13dc099e22bb2d4b4a5fe9815e3 /PKGBUILD
parentbef5a09fec14419999b2c883a7cffa925491aed5 (diff)
downloadaur-dfdf2a838f985c0bb03f18d04a2e7b67df320f5d.tar.gz
support arbitrary integrity checks
The git-makepkg-templates switched to dynamic adaptation to integrity checks chosen in makepkg.conf. [1] The default checksums chosen reflect recommendations from the Arch Linux Wiki and manual pages. [2] [1]: https://github.com/dffischer/git-makepkg-templates/commit/e84d04b [2]: https://aur.archlinux.org/cgit/aur.git/commit/?h=git-makepkg-templates-git&id=c2ccaaa
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80bbbd857320..a1110306b0f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,11 @@ replaces=('firefox-extension-the-fox-only-better')
makedepends+=('git')
source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
-md5sums+=('SKIP')
+for integ in $(get_integlist)
+do
+ typeset -n array="${integ}sums"
+ array+=('SKIP')
+done
provides+=("$_gitname=$pkgver")
conflicts+=("$_gitname")