summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2015-12-23 14:25:45 +0100
committerMichel Zou2015-12-23 14:25:45 +0100
commitcca2416179422180ddcf737e090c636c36018d6a (patch)
treee5485d1521806e635bd531809bb15358432bfb48 /PKGBUILD
downloadaur-cca2416179422180ddcf737e090c636c36018d6a.tar.gz
first import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83065cb06f62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+
+_plugin_name="block-site"
+_plugin_version=1.1.8
+_plugin_id=3145
+pkgdesc="Automagically blocks websites of your choice."
+license=('LGPL')
+
+pkgname=firefox-extension-$_plugin_name
+pkgver=$_plugin_version
+pkgrel=1
+arch=('any')
+url="https://addons.mozilla.org/firefox/addon/$_plugin_id"
+depends=("firefox")
+source=("https://addons.cdn.mozilla.net/user-media/addons/${_plugin_id}/blocksite-${pkgver}-fx.xpi")
+sha256sums=('46b43ff8b6ab8224f1aa02352a6a69f6e1b4c57c309e073967950e4e7385ccbc')
+
+package() {
+ cd $srcdir
+ emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
+ local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
+ install -d $dstdir
+ rm *.xpi
+ mv * $dstdir
+}
+
+