summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFranck STAUFFER2020-08-10 09:29:38 +0200
committerFranck STAUFFER2020-08-10 09:29:38 +0200
commit8949fb2cd1417f0c47b9998a5ea39669ad5591d4 (patch)
tree8c7b15cdafe0f5a2893d556afba95dbfc4c79f51 /PKGBUILD
parent9ed8595af70f66e1d2bb4da486d79a526212cc5f (diff)
downloadaur-8949fb2cd1417f0c47b9998a5ea39669ad5591d4.tar.gz
Reach namcap compliance
- Remove msg calls - Remove unneeded firefox dependence - Fix license dir path - Remove groups variable - Make source unique
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5b0e24c5f84..f7f49f518f2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,18 @@
pkgname='firefox-extension-cookie-autodelete'
pkgver=3.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="Firefox extension that automatically deletes cookies."
license=('MIT')
arch=('any')
url="https://github.com/Cookie-AutoDelete/Cookie-AutoDelete"
-depends=('firefox')
-groups=('firefox-addons')
-source=("https://github.com/Cookie-AutoDelete/Cookie-AutoDelete/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Cookie-AutoDelete/Cookie-AutoDelete/archive/v$pkgver.tar.gz")
b2sums=('09fb14d9950982ab503c6f8489e6acd7435e1bc1a2f3815adde891021c17ffe243bb56687a8a940d1c08a66a273a965d4e0397c2c9940d10218751c317976494')
prepare() {
- msg "Install npm dependencies"
npm --silent -C "Cookie-AutoDelete-$pkgver" install
- msg "Fix vulnerabilities found in installed npm dependencies"
+ # Fix possible vulnerabilities in npm dependencies
npm --silent -C "Cookie-AutoDelete-$pkgver" audit fix
# Force to build release for $pkgver
@@ -31,7 +28,7 @@ build() {
package() {
cd "Cookie-AutoDelete-$pkgver"
- install -Dm644 LICENSE "$pkgver/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd builds
install -Dm644 "Cookie-AutoDelete_${pkgver}_Firefox.xpi" "$pkgdir/usr/lib/firefox/browser/extensions/CookieAutoDelete@kennydo.com.xpi"