summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFadeMind2016-04-11 12:06:18 +0200
committerFadeMind2016-04-11 12:06:18 +0200
commitfc8e49ea324a18fddd602c08c8cdf4bba624a004 (patch)
tree548501201f61a8be7f510c9a14b31698e256952f /PKGBUILD
parentd76a6658b7f311dfb61b8b33966c5d0b317f1067 (diff)
downloadaur-fc8e49ea324a18fddd602c08c8cdf4bba624a004.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc04f5030421..445f2afe3e1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,21 @@
_plugin_name=feedly-notifier
pkgname=firefox-extension-${_plugin_name}
pkgver=2.10.12
-pkgrel=1
+pkgrel=2
pkgdesc="Firefox extension for reading news from rss aggregator Feedly."
license=('MPL 2.0')
arch=('any')
url="https://addons.mozilla.org/firefox/addon/${_plugin_name}/"
depends=("firefox")
+makedepends=('unzip')
source=("https://addons.cdn.mozilla.net/user-media/addons/456474/${_plugin_name/-/_}-${pkgver}-fx.xpi")
+noextract=("${_plugin_name/-/_}-${pkgver}-fx.xpi")
sha256sums=('1d955cb6a82703dcd7204a8c977f0a20be168d4c0edafa900d6180c2d6d69609')
+prepare(){
+ unzip -qqo ${_plugin_name/-/_}-${pkgver}-fx.xpi
+}
+
package() {
cd "$srcdir"
emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf)