summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHezekiah Michael2019-06-02 16:38:10 -0400
committerHezekiah Michael2019-06-02 16:38:10 -0400
commitd6cbc10866a1aadc015915edc3f2e01b3c69b7ff (patch)
treea44e14803d74412353e8384886763a404bbc7213 /PKGBUILD
downloadaur-d6cbc10866a1aadc015915edc3f2e01b3c69b7ff.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48ea4943a725
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Hezekiah Michael <spiritomb at protonmail dot com>
+
+_plugin_name=keepassxc-browser
+_plugin_version=1.4.6
+_plugin_id=3007419
+_plugin_ext="-fx"
+pkgdesc="Official browser plugin for the KeePassXC password manager."
+license=('GPL')
+
+pkgname=firefox-extension-$_plugin_name
+pkgver=$_plugin_version
+pkgrel=1
+arch=('any')
+url="https://addons.mozilla.org/en-US/firefox/addon/keepassxc-browser/"
+depends=("firefox>=52")
+source=("https://addons.mozilla.org/firefox/downloads/file/${_plugin_id}/keepassxc_browser-${pkgver}${_plugin_ext}.xpi")
+noextract=('keepassxc_browser-${pkgver}${_plugin_ext}.xpi')
+md5sums=('1106566f409b9c1363771c1c845c0f57')
+
+package() {
+ cd "${srcdir}"
+ _extension_id="keepassxc-browser@keepassxc.org"
+ _extension_dest="${pkgdir}/usr/lib/firefox/browser/extensions/${_extension_id}"
+ install -Dm644 keepassxc_browser-${pkgver}${_plugin_ext}.xpi "${_extension_dest}.xpi"
+}