summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCharlie Wolf2017-04-05 22:29:30 -0700
committerCharlie Wolf2017-04-05 22:34:36 -0700
commit8e0c036524c70f1c363f101d57c4a965e6a2477d (patch)
tree4984bbe00aa5ed813b2fc456ae4df42956680008 /PKGBUILD
downloadaur-8e0c036524c70f1c363f101d57c4a965e6a2477d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..452b33019254
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=firefox-extension-leechblock
+pkgdesc="LeechBlock is a simple free productivity tool designed to block those time-wasting sites that can suck the life out of your working day."
+pkgver=1.0.8
+pkgrel=1
+arch=('any')
+url="https://addons.mozilla.org/en-US/firefox/addon/leechblock/"
+makedepends=('unzip' )
+depends=("firefox")
+license=('MIT')
+source=("${pkgname}.xpi::https://addons.mozilla.org/firefox/downloads/latest/leechblock/addon-4476-latest.xpi" )
+sha512sums=('00d5c6246b31f25ad319338bfd1f4f099a9178eba8fdbd99bc1ea80eedb240464bb8b14d04dc943838f54e99c03ffb8981f60ecb2589628b76a9cf3caa111ef2')
+noextract=("${pkgname}.xpi")
+
+package(){
+ srcxpi="${srcdir}/${pkgname}.xpi"
+ emid=$(unzip -p "$srcxpi" install.rdf | sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}')
+ install -Dm644 "$srcxpi" "${pkgdir}/usr/lib/firefox/browser/extensions/$emid.xpi"
+}