summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-09-22 01:29:04 +0200
committerXZS2016-09-22 01:29:04 +0200
commit7c34b6a26c0479370eebfb4af0162c4d766f8af5 (patch)
treedd60c8f22c005de0bf5e1ad944295e93f65dce33 /PKGBUILD
parent8e0f82cca8e358366682518f091a6cf4b7179fe4 (diff)
downloadaur-7c34b6a26c0479370eebfb4af0162c4d766f8af5.tar.gz
support arbitrary integrity checks
The git-makepkg-templates switched to dynamic adaptation to integrity checks chosen in makepkg.conf. [1] The default checksums chosen reflect recommendations from the Arch Linux Wiki and manual pages. [2] [1]: https://github.com/dffischer/git-makepkg-templates/commit/e84d04b [2]: https://aur.archlinux.org/cgit/aur.git/commit/?h=git-makepkg-templates-git&id=c2ccaaa
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc3b754a54b7..17a9b2dff2d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,11 @@ depends=('firefox')
makedepends+=('git')
source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
-md5sums+=('SKIP')
+for integ in $(get_integlist)
+do
+ typeset -n array="${integ}sums"
+ array+=('SKIP')
+done
provides+=("$_gitname=$pkgver")
conflicts+=("$_gitname")