summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFadeMind2016-04-07 19:19:38 +0200
committerFadeMind2016-04-07 19:19:38 +0200
commit1ae336a0ded5b13d76775ff8ffa84ac213bbd0bb (patch)
tree1f85e57861b13f9e7edad5f188d7d4910feb676e /PKGBUILD
parent1746fa81d09dd196cc6d530361481017cbd6952d (diff)
downloadaur-1ae336a0ded5b13d76775ff8ffa84ac213bbd0bb.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4955bf5a759d..29c127299a83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,23 @@
# Contributor: Tianjiao Yin <ytj000+aur@gmail.com>
_plugin_name=unmht
-_plugin_version=7.3.0.5
-pkgdesc="view MHT (MHTML) web archive format files, and save complete web pages, including text and graphics, into a single MHT file."
-license=('MPL')
-
pkgname=firefox-extension-${_plugin_name}
-pkgver=${_plugin_version}
+pkgver=8.1.0
pkgrel=1
+pkgdesc="view MHT (MHTML) web archive format files, and save complete web pages, including text and graphics, into a single MHT file"
+license=('MPL')
arch=('any')
-url="https://addons.mozilla.org/firefox/addon/unmht"
+url="https://addons.mozilla.org/firefox/addon/${_plugin_name}"
depends=("firefox")
-source=("${_plugin_name}-${_plugin_version}.xpi::https://addons.cdn.mozilla.net/user-media/addons/8051/${_plugin_name}-${_plugin_version}-sm+an+fx+tb.xpi")
+source=("${_plugin_name}-${pkgver}.xpi::https://addons.cdn.mozilla.net/user-media/addons/8051/${_plugin_name}-${pkgver}-sm+tb+fx+an.xpi")
+sha256sums=('f47f77e04e9938560c50e4684557ebe4c9355b6cacea430ce91d8d16f88e85b3')
package() {
- cd $srcdir
- emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
- local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
- install -d $dstdir
- rm *.xpi
- mv * $dstdir
+ cd $srcdir
+ emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
+ local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
+ install -d $dstdir
+ rm *.xpi
+ mv * $dstdir
}
-sha256sums=('1ef360d4aa7f5991a49c642d9d132de6dab5807729a9207a133602454ab445aa')
+