summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBjörn Bidar2019-03-20 12:13:37 +0100
committerBjörn Bidar2019-03-23 20:14:43 +0100
commit4180c44d41a66413e6a2b0166873f2fa1d432aca (patch)
tree6a52d179995b34ae71f1becc3f36958ed400f09f /PKGBUILD
parent125855e3961cf53dae1bec42036512f5614e3877 (diff)
downloadaur-4180c44d41a66413e6a2b0166873f2fa1d432aca.tar.gz
upkg
- new upstream release - update unity-menubar patch for firefox 66 - update KDE patches for 66 - add missing nasm, python2-psutils, python2-setuptools to makedepends - add pulseaudio to optdepends - add patch to fix build witn rust >= 1.33 - add xz to makedepends as the patch is to huge for the aur
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbb0ae510df6..2eeee5232a75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ _pgo=true
_pkgname=firefox
pkgname=$_pkgname-kde-opensuse
-pkgver=65.0.2
+pkgver=66.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE"
arch=('i686' 'x86_64')
@@ -27,16 +27,17 @@ depends=('mozilla-common' 'libxt' 'startup-notification' 'mime-types'
'libvpx' 'icu' 'libevent' 'nss>=3.28.3' 'nspr>=4.10.6' 'hunspell'
'sqlite' 'libnotify' 'kmozillahelper' 'ffmpeg' 'gtk3')
-makedepends=('unzip' 'zip' 'diffutils' 'python' 'yasm' 'mesa' 'imake'
+makedepends=('unzip' 'zip' 'diffutils' 'python2-setuptools' 'yasm' 'mesa' 'imake'
'xorg-server-xvfb' 'libpulse' 'inetutils' 'autoconf2.13' 'rust'
'cargo' 'mercurial' 'llvm' 'clang'
- 'gtk2' 'nodejs' 'cbindgen')
+ 'gtk2' 'nodejs' 'cbindgen' 'nasm' 'python' 'python2-psutil' 'xz')
optdepends=('networkmanager: Location detection via available WiFi networks'
- 'speech-dispatcher: Text-to-Speech')
+ 'speech-dispatcher: Text-to-Speech'
+ 'pulseaudio: Audio support')
provides=("firefox=${pkgver}")
conflicts=('firefox')
-_patchrev=87f893cf45b9
+_patchrev=eca1c1f2fe50
options=('!emptydirs')
_patchurl=http://www.rosenauer.org/hg/mozilla/raw-file/$_patchrev
_repo=https://hg.mozilla.org/mozilla-unified
@@ -60,6 +61,8 @@ source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
mozilla-1516803.patch
mozilla-1516081.patch
pgo.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1521249
+ 0001-bz-1468911.patch.xz
)
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -83,10 +86,10 @@ prepare() {
cp "$srcdir/mozconfig" .mozconfig
echo -n "$_google_api_key" >google-api-key
- echo "ac_add_options --with-google-api-keyfile=\"$PWD/google-api-key\"" >>.mozconfig
+ echo "ac_add_options --with-google-location-service-api-keyfile=\"$PWD/google-api-key\"" >>.mozconfig
echo -n "$_google_default_client_id $_google_default_client_secret" >google-oauth-api-key
- echo "ac_add_options --with-google-api-keyfile=\"$PWD/google-oauth-api-key\"" >>.mozconfig
+ echo "ac_add_options --with-google-safebrowsing-api-keyfile=\"$PWD/google-oauth-api-key\"" >>.mozconfig
echo -n "$_mozilla_api_key" >mozilla-api-key
echo "ac_add_options --with-mozilla-api-keyfile=\"$PWD/mozilla-api-key\"" >>.mozconfig
@@ -104,6 +107,11 @@ prepare() {
patch -Np1 -i "$srcdir"/2000_system_harfbuzz_support.patch
patch -Np1 -i "$srcdir"/2001_system_graphite2_support.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1521249
+ # patch -Np1 -i ../0001-bz-1468911.patch patch is to large for the AUR
+ xcat "$srcdir"/0001-bz-1468911.patch.xz | patch -Np1
+
+
if [[ $_pgo ]] ; then
# https://bugzilla.mozilla.org/show_bug.cgi?id=1516803
patch -Np1 -i "$srcdir"/mozilla-1516803.patch
@@ -203,14 +211,15 @@ md5sums=('SKIP'
'5cee310a9040ccc5abcf29742b84aeb8'
'05bb69d25fb3572c618e3adf1ee7b670'
'd7ce23a18da21c05cd756766e177834f'
- 'bf2f398aac1ae3d29ae6477325c50c0f'
- 'b2fef35fb6a6a019b597dc559a1d0e12'
+ 'acb2d5930350fb287709283103cfffe2'
+ '7dbeb468613520beba5de17471487e6c'
'f1c5db18b8910b80f1933af1f4fe7c2b'
- '51d059491a3aba215b6cea959e9c5d05'
+ '97cb13d3dfb6222d09070d2c22019deb'
'fe24f5ea463013bb7f1c12d12dce41b2'
'3fa8bd22d97248de529780f5797178af'
'554514bf00a7927a85280f19e52a55fb'
'5b0d39aebb1ce84f89bda300320b851f'
'becf6bf9ceb6008401832c855ccadff9'
'79d27c8896913c7d87b148240995ab69'
- 'f867ae41a722630cc5567e2dcc51676d')
+ 'f867ae41a722630cc5567e2dcc51676d'
+ '47a4608970217485250b7e9bc59609e3')