summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorantsa2017-11-14 21:38:20 +0100
committerantsa2017-11-14 21:38:20 +0100
commit2e435fe1af90554a0bafb8f5ad3388ac1d9d2f26 (patch)
treeb1bbc0d13ef6da6926beef2b147d9702ed938e88 /PKGBUILD
parent8e86abfc88ad7fc2d3e5f9b2c396fd0fc85dccaf (diff)
downloadaur-2e435fe1af90554a0bafb8f5ad3388ac1d9d2f26.tar.gz
59: Fixed icon path and updated dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5bc08b249894..da297a97fc56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=firefox-nightly-de
pkgdesc='Standalone web browser from mozilla.org, nightly build, german'
url='https://nightly.mozilla.org'
pkgver=59.0a1
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
source=(
@@ -17,7 +17,16 @@ sha512sums=('6318a38b87629153fd4214997449e64d3301a7a3e00410f95e83337fbba90a20176
'SKIP'
'SKIP')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353')
-depends=('alsa-lib' 'libxt' 'libnotify' 'mime-types' 'gtk2' 'gtk3' 'sqlite' 'dbus-glib')
+depends=('dbus-glib' 'gtk3' 'libxt' 'nss' 'mime-types')
+optdepends=('pulseaudio: audio support'
+ 'ffmpeg: h.264 video'
+ 'gtk2: flash plugin support'
+ 'hunspell: spell checking'
+ 'hyphen: hyphenation'
+ 'libnotify: notification integration'
+ 'networkmanager: location detection via available WiFi networks'
+ 'speech-dispatcher: text-to-speech'
+ 'startup-notification: support for FreeDesktop Startup Notification')
conflicts=('firefox-nightly')
provides=('firefox-nightly')
@@ -27,6 +36,6 @@ package() {
ln -s /opt/firefox-${pkgver}/firefox "${pkgdir}/usr/bin/firefox-nightly"
install -m644 "${srcdir}"/{firefox-nightly.desktop,firefox-nightly-safe.desktop} "${pkgdir}/usr/share/applications/"
- install -m644 "${srcdir}/firefox/browser/icons/mozicon128.png" "${pkgdir}/usr/share/pixmaps/${pkgname}-icon.png"
+ install -m644 "${srcdir}/firefox/browser/chrome/icons/default/default128.png" "${pkgdir}/usr/share/pixmaps/${pkgname}-icon.png"
install -Dm644 "${srcdir}/vendor.js" "${pkgdir}/opt/firefox-${pkgver}/browser/defaults/preferences/vendor.js"
}