summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2023-05-18 16:26:39 +1200
committerGeorge Rawlinson2023-05-18 16:26:39 +1200
commit57c1a2c92e2974a93f8b24d1a24a18d81f42bd27 (patch)
treecea0dbb26db7d3f0b82f9addd957eaeee8fb7083 /PKGBUILD
parentf526318ddb2ccab1478fe7e0eaeb1b4f83c457d3 (diff)
downloadaur-firefox-nightly-en-gb.tar.gz
upgpkg: firefox-nightly-en-gb
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c41ef872e99..6ef5803aec27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,18 +33,21 @@ arch=('x86_64')
license=('MPL' 'GPL' 'LGPL')
conflicts=('firefox-nightly')
depends=('dbus-glib' 'gtk3' 'libxt' 'nss' 'mime-types' 'python')
-optdepends=('pulseaudio: audio support'
- 'ffmpeg: h.264 video'
- 'hunspell: spell checking'
- 'hyphen: hyphenation'
- 'libnotify: notification integration'
- 'networkmanager: location detection via available WiFi networks'
- 'speech-dispatcher: text-to-speech'
- 'startup-notification: support for FreeDesktop Startup Notification')
+optdepends=(
+ 'pulseaudio: audio support'
+ 'ffmpeg: h.264 video'
+ 'hunspell: spell checking'
+ 'hyphen: hyphenation'
+ 'libnotify: notification integration'
+ 'networkmanager: location detection via available WiFi networks'
+ 'speech-dispatcher: text-to-speech'
+ 'startup-notification: support for FreeDesktop Startup Notification'
+)
provides=("${_pkgname}")
_url="${_base_url}/${_build_id[year]}/${_build_id[month]}/${_build_id[year]}-${_build_id[month]}-${_build_id[day]}-${_build_id[hour]}-${_build_id[min]}-${_build_id[sec]}-mozilla-central-l10n"
_src="${_name}-${_version}.${_lang}.linux-${CARCH}"
_filename="${_build_id[date]}-${_build_id[time]}-${_src}"
+options=('!debug')
source=('firefox-nightly.desktop'
'policies.json'
"${_filename}.tar.bz2::${_url}/${_src}.tar.bz2"