summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Moroni2018-09-12 09:08:59 +0200
committerMichael Moroni2018-09-12 09:08:59 +0200
commitf89adb0d7ab074b001730613cccbed370ec5fc4d (patch)
tree6b080c25ff2c76ee575f935823b35c413f6616ec /PKGBUILD
parent9773cad8b2d24bcd6db49c19ef340b494e70b632 (diff)
downloadaur-f89adb0d7ab074b001730613cccbed370ec5fc4d.tar.gz
Ĝisdatigo al Firefox Nightly 64
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 19 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a24eb319dec1..181b53c408bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,40 +8,40 @@ _lang=eo
pkgname=${_name}-${_channel}-${_lang}
pkgdesc="Standalone Web Browser from Mozilla — Nightly build (${_lang})"
url="https://www.mozilla.org/${_lang}/${_name}/${_channel}"
-_version=63.0a1
-pkgver=63.0a1.20180710
+_version=64.0a1
+pkgver=64.0a1.20180712
pkgrel=1
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
depends=('dbus-glib' 'gtk3' 'libxt' 'nss' 'mime-types')
optdepends=('pulseaudio: audio support'
'ffmpeg: h.264 video'
- 'gtk2: flash plugin support'
'hunspell: spell checking'
'hyphen: hyphenation'
'libnotify: notification integration'
'networkmanager: location detection via available WiFi networks'
'speech-dispatcher: text-to-speech'
'startup-notification: support for FreeDesktop Startup Notification')
-_url="https://ftp.mozilla.org/pub/${_name}/${_channel}/latest-mozilla-central-l10n"
-_urlUS="https://ftp.mozilla.org/pub/${_name}/${_channel}/latest-mozilla-central"
+_url="https://download-installer.cdn.mozilla.net/pub/${_name}/${_channel}/latest-mozilla-central-l10n"
+_urlUS="https://download-installer.cdn.mozilla.net/pub/${_name}/${_channel}/latest-mozilla-central"
_src="${_name}-${_version}.${_lang}.linux"
_srcUS="${_name}-${_version}.en-US.linux"
-source=("${pkgname}.desktop" 'vendor.js')
-# source_i686=("${_url}/${_src}-i686.tar.bz2"{,.asc} "${_urlUS}/${_srcUS}-i686.txt")
-# source_x86_64=("${_url}/${_src}-x86_64.tar.bz2"{,.asc} "${_urlUS}/${_srcUS}-x86_64.txt")
-source_i686=("${_url}/${_src}-i686.tar.bz2" "${_urlUS}/${_srcUS}-i686.txt")
-source_x86_64=("${_url}/${_src}-x86_64.tar.bz2" "${_urlUS}/${_srcUS}-x86_64.txt")
-sha512sums=('ba6d165fb119de50d1105614ed063c26e4d3a8877cbab2a71e875458209218ade173dacdae2f06bf66dba39ebc005f371d74d68baa0c8bc7dbdd23ded077eee6'
- 'bae5a952d9b92e7a0ccc82f2caac3578e0368ea6676f0a4bc69d3ce276ef4f70802888f882dda53f9eb8e52911fb31e09ef497188bcd630762e1c0f5293cc010')
-# sha512sums_i686=('SKIP' 'SKIP' 'SKIP')
-# sha512sums_x86_64=('SKIP' 'SKIP' 'SKIP')
-sha512sums_i686=('SKIP' 'SKIP')
-sha512sums_x86_64=('SKIP' 'SKIP')
-validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla's GnuPG release key
+_filename="$(date +%Y%m%d)-${_src}"
+source=("${pkgname}.desktop" 'policies.json')
+source_i686=("${_filename}-i686.tar.bz2"::"${_url}/${_src}-i686.tar.bz2"
+ "${_filename}-i686.tar.bz2.asc"::"${_url}/${_src}-i686.tar.bz2.asc"
+ "${_filename}-i686.txt"::"${_urlUS}/${_srcUS}-i686.txt")
+source_x86_64=("${_filename}-x86_64.tar.bz2"::"${_url}/${_src}-x86_64.tar.bz2"
+ "${_filename}-x86_64.tar.bz2.asc"::"${_url}/${_src}-x86_64.tar.bz2.asc"
+ "${_filename}-x86_64.txt"::"${_urlUS}/${_srcUS}-x86_64.txt")
+sha512sums=('252337cd79c4e5b38230523de57b83759d7ebc83e9b17052e2b159174b04121774100ceb5b6099cede910c9df5cc0473589561a73ff55be8535e9a1d0bf3727e'
+ '5ed67bde39175d4d10d50ba5b12063961e725e94948eadb354c0588b30d3f97d2178b66c1af466a6e7bd208ab694227a1391c4141f88d3da1a1178454eba5308')
+sha512sums_i686=('SKIP' 'SKIP' 'SKIP')
+sha512sums_x86_64=('SKIP' 'SKIP' 'SKIP')
+validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla’s GnuPG release key
pkgver() {
- echo "${_version}.$(head -n1 ${_srcUS}-${CARCH}.txt | cut -c-8)"
+ echo "${_version}.$(head -n1 ${_filename}-${CARCH}.txt | cut -c-8)"
}
package() {
@@ -64,7 +64,7 @@ package() {
done
# Disable auto-updates
- install -Dm644 "${srcdir}"/vendor.js -t "${pkgdir}"/${OPT_PATH}/browser/defaults/preferences
+ install -Dm644 "${srcdir}"/policies.json -t "${pkgdir}"/${OPT_PATH}/distribution
# Use system-provided dictionaries
rm -rf "${pkgdir}"/${OPT_PATH}/{dictionaries,hyphenation}