summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRamana Kumar2015-06-15 12:12:27 +0530
committerRamana Kumar2015-06-15 12:12:27 +0530
commit1d9f3d74b8b701b8623033b7e77deb72fbdacc2a (patch)
tree9fb4974bcff32f757c76c37eec5f23a4754f700a /PKGBUILD
downloadaur-1d9f3d74b8b701b8623033b7e77deb72fbdacc2a.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e182260e6857
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Ramana Kumar <firstname@member.fsf.org>
+pkgname=firefox-sync
+pkgver=20150305
+pkgrel=1
+pkgdesc="Speed up Firefox using tmpfs"
+arch=('i686' 'x86_64')
+url="http://wiki.archlinux.org/index.php/Speed-up_Firefox_using_tmpfs"
+license=('GPL')
+depends=('rsync' 'firefox')
+makedepends=('bash')
+source=(${pkgname})
+md5sums=('4e7949eaed8f284233d2ecdecc28534c')
+package() {
+ sed -i "3 c\
+LINK=$(ls -d1 ~/.mozilla/firefox/*.default | head -n 1 | xargs basename)
+" $pkgname
+ install -D ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ cd ${pkgdir}/usr/bin
+ bash -c '{
+echo "#!/bin/bash"
+echo "firefox-sync && firefox && firefox-sync"
+} > syncfox'
+ find ${pkgdir}/usr/bin -type f -exec chmod 755 {} \;
+ find ${pkgdir}/usr/bin -type d -exec chmod 755 {} \;
+}