summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-04-22 11:40:44 +0200
committerXZS2016-04-22 11:40:44 +0200
commit4bded196e62a0c9f72c9b70e1f83b64d1a9add89 (patch)
treee59ef12d3a2a5c32f7e77133c93c895c87fcf84f /PKGBUILD
parentc9d6cf46564abb91c17f3ef09ed2d17692804a04 (diff)
downloadaur-4bded196e62a0c9f72c9b70e1f83b64d1a9add89.tar.gz
exclude hidden filed in subdirectories
Despite the wild card * not coping hidden files, this does not exclude such in subdirectories. A reliable method to exclude files by a pattern like "starting with a dot" would be rsync. But to not pull it in as an additional dependency, copy and find are preferred.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce84a7448686..315f7e35cd51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ conflicts+=("$_gitname")
# Move down repository content for easier access by following functions.
prepare() {
- cp -rf --reflink=auto "$_gitname"/* .
+ cp -rfT --reflink=auto "$_gitname" .
rm -rf "$_gitname"
}