summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-09-22 01:29:23 +0200
committerXZS2016-09-22 01:29:23 +0200
commitcb13d05205840ed744f554589faaa013743ddc61 (patch)
tree47dddfe8ea705c07ba6502ad875f53b87537350b /PKGBUILD
parent1126dfd998d5d9c69591bc08829655b35b70153a (diff)
downloadaur-cb13d05205840ed744f554589faaa013743ddc61.tar.gz
support arbitrary integrity checks
The git-makepkg-templates switched to dynamic adaptation to integrity checks chosen in makepkg.conf. [1] The default checksums chosen reflect recommendations from the Arch Linux Wiki and manual pages. [2] [1]: https://github.com/dffischer/git-makepkg-templates/commit/e84d04b [2]: https://aur.archlinux.org/cgit/aur.git/commit/?h=git-makepkg-templates-git&id=c2ccaaa
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8170b0221a58..11a28465c8d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,11 @@ makedepends=('unzip' 'zip')
makedepends+=('git')
source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
-md5sums+=('SKIP')
+for integ in $(get_integlist)
+do
+ typeset -n array="${integ}sums"
+ array+=('SKIP')
+done
provides+=("$_gitname=$pkgver")
conflicts+=("$_gitname")