summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-04-23 01:24:53 +0200
committerXZS2016-04-23 01:24:53 +0200
commit96ee3885c5dbbfca5369fbe6c0c7029ac6008792 (patch)
treed862ce860caff02b73bcd230ca99883d03c59e5f /PKGBUILD
parent22a2b9d9227339744fb1c2c8b90b7b5cc1dd09aa (diff)
downloadaur-96ee3885c5dbbfca5369fbe6c0c7029ac6008792.tar.gz
do not install version file
The file is just used to set up package information and relations. It is not needed in the package contents. When included nonetheless, it can cause Firefox to consider the Add-On as signed because of the additional file lacking any checksum or verification. Hiding it effectively excludes it from the installation.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1dc277baad6..4ba2b809c00a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firefox-theme-ft-deepdark
pkgver=14.0
-pkgrel=2
+pkgrel=3
pkgdesc='Smooth dark theme for Firefox'
url='https://addons.mozilla.org/en-us/firefox/addon/ft-deepdark/'
license=('custom:noncommercial')
@@ -14,7 +14,7 @@ md5sums=('3990c3cb5d16b325b621a91518c95064')
source+=(
"${pkgname}.zip::https://addons.mozilla.org/firefox/downloads/latest/${pkgname#*-*-}/platform:2/"
- "version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/${pkgname#*-*-}"
+ ".version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/${pkgname#*-*-}"
)
md5sums+=('SKIP')
noextract+=("${pkgname}.zip")
@@ -38,7 +38,7 @@ pkgver() {
# Retrieve current compatibility information from addons.mozilla.org API.
query-version() {
- xmllint version --xpath \
+ xmllint .version --xpath \
"//application[appID='$2']/$1_version/text()"
}
version-range() {