summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-10-31 18:31:08 +0100
committerXZS2016-10-31 18:31:08 +0100
commit9ed9f4125b1b54c062af9ccfa7b6b370b732844f (patch)
tree77d7a561bbaf27bc68dfb67b356e891ea7f4ebe0 /PKGBUILD
parent05e2459ffcf485705212fac588892b00dd6cd550 (diff)
downloadaur-9ed9f4125b1b54c062af9ccfa7b6b370b732844f.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 559c1ac93bac..618f911d061d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=firefox-theme-nasa-night-launch
pkgdesc="Dark theme for Firefox. Inspired by the night launch of STS-116."
pkgver=0.6.20160329
-pkgrel=3
+pkgrel=4
url="http://home.comcast.net/~username54321/starfield/index.html"
license=('custom')
md5sums=('79aaf0d3b9cc2aaa48e5776901f4aab0')
@@ -43,9 +43,18 @@ query-version() {
xmllint .version --xpath \
"//application[appID='$2']/$1_version/text()"
}
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {