summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGu1ll0me2019-07-31 08:42:04 -0400
committerGu1ll0me2019-07-31 08:42:04 -0400
commitd9e07721d007acbf78618a35594da3724467c4cf (patch)
treeaa23576a7fbd95d3a35fc109632f8a7f843f5dbe /PKGBUILD
parentfc944365275d029f6a8969bc433e7906d74e6075 (diff)
downloadaur-d9e07721d007acbf78618a35594da3724467c4cf.tar.gz
Update to 68.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 22 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9fd50e4cddbc..7bf92ac8b772 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,39 @@
# Maintainer: aimileus <me at aimileus dot nl>
-# Maintainer: Gui||aume <michaudg@gmail.com>
+# Maintainer: Gu1ll0me <michaudg@gmail.com>
pkgname=firefox-ubuntu-bin
_pkgname=firefox
-pkgver=61.0.1
+pkgver=68.0.1
pkgrel=1
-_ubuntuver="$pkgver+build1-0ubuntu0.18.04.1_amd64"
+_ubuntuver="$pkgver+build1-0ubuntu0.19.04.1_amd64"
pkgdesc="Standalone web browser from mozilla.org with Ubuntu patches (binary)"
arch=("x86_64")
url="https://www.mozilla.org/firefox/"
license=('GPL' 'LGPL' 'MPL')
-depends=(
- 'dbus-glib'
- 'ffmpeg'
- 'gtk3'
- 'hunspell'
- 'icu'
- 'libpulse'
- 'libvpx'
- 'libxt'
- 'mime-types'
- 'mozilla-common'
- 'nss'
- 'sqlite'
- 'startup-notification'
- 'ttf-font'
-)
-optdepends=(
- 'libnotify: Notification integration'
- 'networkmanager: Location detection via available WiFi networks'
- 'pulseaudio: Audio support'
- 'speech-dispatcher: Text-to-Speech'
-)
+depends=('mozilla-common' 'libxt' 'startup-notification' 'mime-types'
+ 'dbus-glib' 'hicolor-icon-theme'
+ 'libvpx' 'icu' 'libevent' 'nss>=3.28.3' 'nspr>=4.10.6' 'hunspell'
+ 'sqlite' 'libnotify' 'ffmpeg' 'gtk3'
+ # system av1
+ 'dav1d' 'aom'
+ # system harfbuzz
+ 'harfbuzz'
+ # system graphite
+ 'graphite'
+ # system webp
+ 'libwebp'
+ # system libevent
+ 'libevent'
+ )
+optdepends=('networkmanager: Location detection via available WiFi networks'
+ 'speech-dispatcher: Text-to-Speech'
+ 'pulseaudio: Audio support')
provides=('firefox' 'firefox-ubuntu')
conflicts=('firefox' 'firefox-ubuntu')
source=("http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_$_ubuntuver.deb")
-sha256sums=('6c6afff03dd588f4321f9415b8e854620075ae0d7bc8780c47dc03b0ed01ebc2')
+sha256sums=('cdb09a3dc87a60e2c4a8adade8f509bb4ac6b5dd674d1c7a38028df93452918c')
prepare() {
# Don't extract copyright files, which are included in the licenses package