summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFinn Petersen2021-07-22 21:14:39 +0200
committerFinn Petersen2021-07-22 21:44:04 +0200
commit5c5aa8c264c82a8f3b4ec64277b5580a7345250b (patch)
tree5ab05c67933ea8305762f33803bf99657bf83bad /PKGBUILD
downloadaur-5c5aa8c264c82a8f3b4ec64277b5580a7345250b.tar.gz
Provide a package to use firefox autoconfig from user home
Adds configuration files to the firefox installation in /usr/lib/firefox so that '$HOME/.mozilla/firefox/user.js' is loaded to set configuration settings. The file in the user home can be put under source control and synced between machines.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..182d50d2a436
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Finn Petersen <fp7@posteo.net>
+pkgname=firefox-user-autoconfig
+pkgver=1
+pkgrel=1
+pkgdesc="Make firefox use a source controllable autoconfig file in the user home"
+url="https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig"
+arch=("any")
+license=("Unlicense")
+optdepends=("firefox")
+source=("autoconfig.js"
+ "firefox.cfg")
+backup=("usr/lib/firefox/defaults/pref/autoconfig.js"
+ "usr/lib/firefox/firefox.cfg")
+sha256sums=('e46fd52157485b8567d486142e708ebd653823c29d839485821c950fdf614d36'
+ '232e722832647cab17e3be69cc817edb90dadfd4a64ddc58fe5b8bf7224a7cf8')
+
+package() {
+ cd "$srcdir";
+ install -D -m 0644 autoconfig.js "$pkgdir/usr/lib/firefox/defaults/pref/autoconfig.js";
+ install -D -m 0644 firefox.cfg "$pkgdir/usr/lib/firefox/firefox.cfg";
+}