summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJacqueline Fisher2023-09-14 20:17:52 -0500
committerJacqueline Fisher2023-09-14 20:17:52 -0500
commit5a6ca51abb70ea1cc62f4cf30d105e5bf7dc60ef (patch)
treed9e1d2b3858ed59a38fbc25864cf57e5fbdd9b99 /PKGBUILD
parentf179bfea74ccb4c7aa0c1eb68a319a99b904abcd (diff)
downloadaur-5a6ca51abb70ea1cc62f4cf30d105e5bf7dc60ef.tar.gz
Update firestorm to 6.6.14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d91287e22da7..65c9c6eea1f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,8 @@
# Contributor: Nicky D
pkgname=firestorm
-pkgver=6.6.8
+_pkgver=6.6.14
+pkgver=6.6.14.69598
pkgrel=1
pkgdesc="An open source 3D browser for Second Life & OpenSIM metaverse."
arch=('i686' 'x86_64')
@@ -19,16 +20,21 @@ optdepends=(
'mesa-libgl: For Intel, Radeon, Nouveau support'
'nvidia-libgl: for NVIDIA support'
'nvidia-utils: for NVIDIA support')
-makedepends=('cmake' 'gcc' 'make' 'python-virtualenv' 'python-pip' 'git' 'boost' 'xz')
-conflicts=('firestorm-bin' 'firestorm-nightly' 'firestorm-beta-bin')
-provides=('firestorm')
+makedepends=('cmake' 'python-virtualenv' 'python-pip' 'git' 'boost' 'xz')
+conflicts=('firestorm-bin' 'firestorm-git')
#options=(debug !strip)
-source=("$pkgname"::"git+https://vcs.firestormviewer.org/phoenix-firestorm#branch=Firestorm_$pkgver" "fs-build-variables"::'git+https://vcs.firestormviewer.org/fs-build-variables' 'firestorm.desktop' 'firestorm.launcher')
-md5sums=('SKIP' 'SKIP' '5e3dade65948533ff8412da776029179' '3daa9e24492337e62bcac318df4ab370')
+source=("$pkgname"::"git+https://vcs.firestormviewer.org/phoenix-firestorm#branch=Firestorm_$_pkgver" "fs-build-variables"::'git+https://vcs.firestormviewer.org/fs-build-variables' 'firestorm.desktop' 'firestorm.launcher')
+sha512sums=('SKIP'
+ 'SKIP'
+ '9467b7e497dc98121df583e2432526541035fe18b254b8a9a8ed5306f4659d66b8df33452cafc94264ef7237bbd6fd5e590be42da8de8dba7a28c34435d709c6'
+ '768e7ecd339ab17bfd6aa652d99f3dd60325739e778a5bfce74a57ce7791b6a15d78a4c0b7ecc64475ea53e84faa6b1f6191fb1753f87e5b0bb772d4da335b5c')
pkgver() {
- cat $(find "$srcdir/$pkgname/indra/newview/" -type f -iname viewer_version.txt)
+ _pkgver=$(find "$srcdir/$pkgname/indra/newview/" -type f -iname viewer_version.txt -exec cat {} +)
+ cd "$srcdir/$pkgname"
+ _revnum=$(git rev-list --count HEAD)
+ printf "%s.%s" $_pkgver $_revnum
}
prepare() {
@@ -55,9 +61,11 @@ build() {
package() {
mkdir -p "$pkgdir/opt/firestorm"
mkdir -p "$pkgdir/usr/share/applications"
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/512x512/apps"
cp -rT "$pkgname/build-linux-x86_64/newview/packaged" "$pkgdir/opt/firestorm"
install -Dm644 "firestorm.desktop" "$pkgdir/usr/share/applications/firestorm.desktop"
+ install -Dm644 "$pkgname/build-linux-x86_64/newview/packaged/firestorm_icon.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/firestorm.png"
install -Dm755 "firestorm.launcher" "$pkgdir/usr/bin/firestorm"
}