summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike Swanson2015-07-12 17:02:17 -0700
committerMike Swanson2015-07-12 17:02:17 -0700
commit96f4385f7564e566ef1006d726c949ca346cf603 (patch)
tree2e97d26b1558c16bbf258b3fdb17ab87c3da04a3 /PKGBUILD
parent9631f9b6d0b7442b7447b10613bf1fac225f3534 (diff)
downloadaur-96f4385f7564e566ef1006d726c949ca346cf603.tar.gz
Fix the loading of 32-bit DRI modules on 64-bit OSes.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1608b0fb113..f0a1bca9462f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=firestorm-bin
pkgver=4.7.1.45325
-pkgrel=1
+pkgrel=2
pkgdesc="Firestorm is a feature-packed third-party viewer for Second Life."
url="http://www.firestormviewer.org/"
license=('GPL')
@@ -14,6 +14,7 @@ if [ "$CARCH" = "i686" ]; then
optdepends=(
'libpulse: for PulseAudio support'
'alsa-lib: for ALSA support'
+ 'mesa-libgl: For Intel, Radeon, Nouveau support'
'nvidia-utils: for NVIDIA support'
'nvidia-libgl: for NVIDIA support'
'flashplugin: for inworld Flash support'
@@ -29,6 +30,7 @@ elif [ "$CARCH" = "x86_64" ]; then
optdepends=(
'lib32-libpulse: for PulseAudio support'
'lib32-alsa-lib: for ALSA support'
+ 'lib32-mesa-libgl: For Intel, Radeon, Nouveau support'
'lib32-nvidia-utils: for NVIDIA support'
'lib32-nvidia-libgl: for NVIDIA support'
'lib32-flashplugin: for inworld Flash support'
@@ -37,20 +39,25 @@ elif [ "$CARCH" = "x86_64" ]; then
fi
install=firestorm.install
source=("http://downloads.firestormviewer.org/linux/Phoenix_FirestormOS-Beta_i686_$pkgver.tar.xz"
+ "0001-firestorm-libgl-path.patch"
"firestorm.install"
"firestorm.desktop"
"firestorm.launcher")
sha256sums=('87ddc945c8a729d3b077c719445df97cb2caf4c49934e85daee4735c9036f320'
+ '70d0b8742fc0d655cf27a927a308ccad054dafe17dd4db91d39d11f48e564fda'
'cd919be5e2d28ff86e9b51ffe1076ba8c13acf9c0953fc2f4bb78fe7e79cdbb3'
'6dffebc474fd98d23bf8d9f4a7592795642dbddf3a0b585f89d25ff11ae15cc1'
'b2ce32d268f76f4324807d50c4098a3480b489ec447133ce8d9b9c4a7bc05530')
+prepare() {
+ mv "$srcdir/Phoenix_FirestormOS-Beta_i686_$pkgver" "$srcdir/firestorm"
+ cd "$srcdir/firestorm"
+ patch -i ../0001-firestorm-libgl-path.patch
+}
+
package() {
cd "$srcdir"
- # Rename Data Directory
- mv Phoenix_FirestormOS-Beta_i686_$pkgver firestorm
-
# Fix fontconfig >= 2.9.0 issue
ln -si libfontconfig.so.1.4.4 firestorm/lib/libfontconfig.so.1