summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2016-01-24 12:49:44 +0100
committerMaxime Gauduin2016-01-24 12:49:44 +0100
commit763f2bc9ceaa533a859d720a9abd1664aade2df5 (patch)
tree1ad7a1a8472b22efe08c6c5d2bcc2923d80f1089 /PKGBUILD
parent6a8af7a4ea0005f327079a0a3732e271f904a404 (diff)
downloadaur-763f2bc9ceaa533a859d720a9abd1664aade2df5.tar.gz
firewalld-git 0.3.14.2.r190.d7d68f8-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de7d4b08f7de..00246f28fe7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,19 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=firewalld-git
-pkgver=0.3.14.2.r50.d762bf8
+pkgver=0.3.14.2.r190.d7d68f8
pkgrel=1
pkgdesc='A firewall daemon with D-BUS interface providing a dynamic firewall'
arch=('any')
url='http://fedorahosted.org/firewalld'
license=('GPL2')
-depends=('ebtables' 'gtk3' 'iptables' 'libnotify' 'networkmanager' 'python-slip')
+depends=('dbus-glib' 'ebtables' 'ipset' 'iptables' 'python-slip')
makedepends=('docbook-xsl' 'git' 'intltool')
+optdepends=('bash-completion: bash completion support'
+ 'gtk3: firewall-config'
+ 'libnotify: firewall-applet'
+ 'libnm-glib: firewall-config and firewall-applet'
+ 'python-pyqt4: firewall-applet')
backup=('etc/conf.d/firewalld'
'etc/firewalld/firewalld.conf')
provides=('firewalld')
@@ -17,7 +22,7 @@ install='firewalld.install'
source=('git+https://github.com/t-woerner/firewalld.git'
'firewalld-arch.patch')
sha256sums=('SKIP'
- '91dbd5c580d3603e77c905880ca99ebddf398cf72f86ad37d0134ff7aa119ced')
+ '0e10b2dd4eb2b3ca436c9539c9cdd5e612c0f150f51f5c7d50743700437a2bee')
pkgver() {
cd firewalld
@@ -40,6 +45,13 @@ build () {
--localstatedir='/var' \
--sbindir='/usr/bin' \
--sysconfdir='/etc' \
+ --with-iptables='/usr/bin/iptables' \
+ --with-iptables-restore='/usr/bin/iptables-restore' \
+ --with-ip6tables='/usr/bin/ip6tables' \
+ --with-ip6tables-restore='/usr/bin/ip6tables-restore' \
+ --with-ebtables='/usr/bin/ebtables' \
+ --with-ebtables-restore='/usr/bin/ebtables-restore' \
+ --with-ipset='/usr/bin/ipset' \
--disable-schemas-compile
make
}