summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorElliott Saille2019-05-23 12:15:05 -0500
committerElliott Saille2019-05-23 12:15:05 -0500
commit7a286c166614c773765dad51d6f8f116202bd793 (patch)
treefa6b41f3e0b551c8728bd2ac7565d0cf387cd36a /PKGBUILD
parent4bb5ab293b0960990eeafcb23a6bab81ed5f5d5b (diff)
downloadaur-7a286c166614c773765dad51d6f8f116202bd793.tar.gz
Update PKGBUILD to build from latest sources after adoption
PKGBUILD is now almost verbatim copy of the official PKGBUILD from the community repo with out targeting a specific tag.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD97
1 files changed, 62 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c208cafc684..2aca9bf19b70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,74 @@
+# Maintainer: Elliott Saille <me+aur@esaille.me>
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: unikum <unikum.pm@gmail.com>
+# Contributor: speed145a <jonathan@tagchapter.com>
+_pkgname=firewalld
pkgname=firewalld-git
-pkgver=0.4.4.1.r1.490b492
+pkgver=0.6.999
pkgrel=1
-pkgdesc='A firewall daemon with D-BUS interface providing a dynamic firewall'
-arch=('any')
-url='http://fedorahosted.org/firewalld'
-license=('GPL2')
-depends=('dbus-glib' 'ebtables' 'ipset' 'iptables' 'python-slip')
-makedepends=('docbook-xsl' 'git' 'intltool')
-optdepends=('bash-completion: bash completion support'
- 'gtk3: firewall-config'
- 'libnotify: firewall-applet'
- 'libnm-glib: firewall-config and firewall-applet'
- 'python-pyqt4: firewall-applet')
-backup=('etc/conf.d/firewalld'
- 'etc/firewalld/firewalld.conf')
-provides=('firewalld')
+pkgdesc='Firewall daemon with D-Bus interface'
+arch=(any)
+url='https://firewalld.org/'
+license=(GPL2)
+
+depends=(
+ dconf
+ glib2
+ hicolor-icon-theme
+ nftables
+ python-decorator
+ python-gobject
+ python-slip
+)
+
+makedepends=(
+ docbook-xsl
+ ebtables
+ git
+ intltool
+ ipset
+ iptables
+)
+
+optdepends=(
+ 'bash-completion: bash completion'
+ 'ebtables: old backend'
+ 'gtk3: firewall-config'
+ 'ipset: old backend'
+ 'iptables: old backend'
+ 'libnm-glib: firewall-config and firewall-applet'
+ 'libnotify: firewall-applet'
+ 'python-pyqt5: firewall-applet'
+)
+
conflicts=('firewalld')
-install='firewalld.install'
-source=('git+https://github.com/t-woerner/firewalld.git'
- 'firewalld-arch.patch')
-sha256sums=('SKIP'
- '5c0c49e125426d561c4099df639ab6dd7073a6d17ae1c130d235cc2397c568c2')
+provides=('firewalld')
-pkgver() {
- cd firewalld
+backup=(
+ etc/conf.d/firewalld
+ etc/firewalld/firewalld.conf
+)
- git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./;'
-}
+source=(
+ git+https://github.com/firewalld/firewalld.git
+ firewalld-sysconfigdir.patch
+)
+
+sha256sums=('SKIP'
+ 'cf7d655230c43acf10a0f97dffdbcba136729967c8b9a25a930871d54a589834')
prepare() {
cd firewalld
- patch -Np1 -i ../firewalld-arch.patch
- ./autogen.sh
+ # Backport zsh completion
+ #git cherry-pick -n b0d8723d85651cacbb21f2168d92f3c7052e909d
+ patch -Np1 -i ../firewalld-sysconfigdir.patch
+
+ NOCONFIGURE='true' ./autogen.sh
}
-build () {
+build() {
cd firewalld
./configure \
@@ -45,14 +76,8 @@ build () {
--localstatedir='/var' \
--sbindir='/usr/bin' \
--sysconfdir='/etc' \
- --with-iptables='/usr/bin/iptables' \
- --with-iptables-restore='/usr/bin/iptables-restore' \
- --with-ip6tables='/usr/bin/ip6tables' \
- --with-ip6tables-restore='/usr/bin/ip6tables-restore' \
- --with-ebtables='/usr/bin/ebtables' \
- --with-ebtables-restore='/usr/bin/ebtables-restore' \
- --with-ipset='/usr/bin/ipset' \
- --disable-schemas-compile
+ --disable-schemas-compile \
+ --disable-sysconfig
make
}
@@ -60,6 +85,8 @@ package() {
cd firewalld
make DESTDIR="${pkgdir}" install
+ #mv "${pkgdir}"/usr/share/dbus-1
+ install -Dm 644 shell-completion/zsh/_firewalld -t "${pkgdir}"/usr/share/zsh/site-functions/
}
# vim: ts=2 sw=2 et: