summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoramoka2021-04-19 16:10:02 -0400
committeramoka2021-04-19 16:10:02 -0400
commita5cd54becdd93d07e77886593831088033c929c4 (patch)
tree1bf274c843a659878a515d514a4d66cee1413e57 /PKGBUILD
parent906aedfb6008e49f8b74ac35087a687adb1e7fd8 (diff)
downloadaur-a5cd54becdd93d07e77886593831088033c929c4.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 17 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dabcabf8f2b4..d5b592bc5613 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
-# Maintainer: Elliott Saille <me+aur@esaille.me>
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: Amanoel Dawod <amoka at amanoel dot com>
+# Contributor: Elliott Saille <me+aur@esaille.me>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: unikum <unikum.pm@gmail.com>
# Contributor: speed145a <jonathan@tagchapter.com>
-_pkgname=firewalld
pkgname=firewalld-git
+pkgver=r3296.f3bd1297
+pkgrel=1
epoch=1
-pkgver=r3151.956db5ec
-pkgrel=4
-pkgdesc='Firewall daemon with D-Bus interface'
+pkgdesc="Firewall daemon with D-Bus interface (from git)"
arch=(any)
-url='https://firewalld.org/'
+url="https://firewalld.org/"
license=(GPL2)
-
depends=(
dconf
glib2
@@ -22,40 +21,30 @@ depends=(
python-gobject
python-slip
)
-
makedepends=(
docbook-xsl
- ebtables
git
intltool
ipset
- iptables
)
-
optdepends=(
'bash-completion: bash completion'
- 'ebtables: old backend'
'gtk3: firewall-config'
- 'ipset: old backend'
- 'iptables: old backend'
- 'libnm-glib: firewall-config and firewall-applet'
+ 'ipset: ipset support'
'libnotify: firewall-applet'
+ 'nm-connection-editor: firewalld-applet'
'python-pyqt5: firewall-applet'
)
-
-conflicts=('firewalld')
provides=('firewalld')
-
+conflicts=('firewalld')
backup=(
etc/conf.d/firewalld
etc/firewalld/firewalld.conf
)
-
source=(
git+https://github.com/firewalld/firewalld.git
firewalld-sysconfigdir.patch
)
-
sha256sums=('SKIP'
'cf7d655230c43acf10a0f97dffdbcba136729967c8b9a25a930871d54a589834')
@@ -66,35 +55,25 @@ pkgver() {
prepare() {
cd firewalld
-
- # Backport zsh completion
- #git cherry-pick -n b0d8723d85651cacbb21f2168d92f3c7052e909d
patch -Np1 -i ../firewalld-sysconfigdir.patch
-
- NOCONFIGURE='true' ./autogen.sh
+ NOCONFIGURE=true ./autogen.sh
}
build() {
cd firewalld
-
./configure \
- --prefix='/usr' \
- --localstatedir='/var' \
- --sbindir='/usr/bin' \
- --sysconfdir='/etc' \
+ --prefix=/usr \
+ --localstatedir=/var \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
--disable-schemas-compile \
--disable-sysconfig
make
}
package() {
- cd firewalld
-
- make DESTDIR="${pkgdir}" install
- #mv "${pkgdir}"/usr/share/dbus-1
- install -Dm 644 shell-completion/zsh/_firewalld -t "${pkgdir}"/usr/share/zsh/site-functions/
+ make DESTDIR="${pkgdir}" -C firewalld install
+ export PYTHONHASHSEED=0
python -m compileall -d /usr/lib "$pkgdir/usr/lib"
python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"
}
-
-# vim: ts=2 sw=2 et: