summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSanskritFritz2019-03-03 23:55:04 +0100
committerSanskritFritz2019-03-03 23:55:04 +0100
commit6ee39eeeb68e050221d347ab9c5ce048a27830d5 (patch)
tree5284b5dbc6717e209d314582a330f3334de7d98c /PKGBUILD
parent8da1e112d3b4e89684f0bbb47d75fff48cc85f33 (diff)
downloadaur-6ee39eeeb68e050221d347ab9c5ce048a27830d5.tar.gz
Upstream switched to cmake
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d96ee40cee87..72b190724ec9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=fish-git
_gitname="fish-shell"
-pkgver=3.0.0.r164.g455959ae
+pkgver=3.0.2.r546.ge11c3f352
pkgrel=1
epoch=2
pkgdesc="User friendly shell intended mostly for interactive use."
@@ -16,7 +16,7 @@ license=("GPL2")
depends=('ncurses')
optdepends=('python: fish_update_completions and other tools'
'xsel: clipboard integration')
-makedepends=('doxygen' 'git' 'ncurses')
+makedepends=('cmake' 'doxygen' 'git' 'ncurses')
provides=('fish' 'fish-shell')
conflicts=('fish' 'fish-shell')
install='fish.install'
@@ -31,13 +31,18 @@ pkgver() {
build() {
cd "$srcdir/$_gitname"
-
- autoreconf --no-recursive
- ./configure --prefix=/usr --sysconfdir=/etc --docdir=/usr/share/doc/fish --without-included-pcre2
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
make
+
}
package() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/$_gitname/build"
make DESTDIR="$pkgdir" install
+
+ # https://github.com/fish-shell/fish-shell/issues/5719
+ mv "$pkgdir/usr/local/share/fish/"* "$pkgdir/usr/share/fish"
+ rmdir "$pkgdir/usr/local/share/fish" "$pkgdir/usr/local/share" "$pkgdir/usr/local"
}