summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAkatsuki Rui2023-02-20 16:27:23 +0800
committerAkatsuki Rui2023-02-20 16:29:14 +0800
commitb071d9033be66517b73ff1ffcc3f77578b891566 (patch)
tree0cdb8626f3d834a05a370434bebc39a8be0967a6 /PKGBUILD
parent8a74fa0f47a7ae235e3ea7eed27c1efc40520d69 (diff)
downloadaur-b071d9033be66517b73ff1ffcc3f77578b891566.tar.gz
New makedepends cargo & clang and new checkdepends procps-ng
RIIR https://github.com/fish-shell/fish-shell/pull/9512
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD88
1 files changed, 55 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d0f8d56b6f4..8c238b376a5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,56 +2,78 @@
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: Jan Fader <jan.fader@web.de>
# Contributor: Stephen Drodge <stephen.drodge@gmail.com>
-# Contributor: akiirui (AUR)
+# Contributor: Akatsuki Rui <aur@akii.work>
# Maintainer: SanskritFritz (gmail)
pkgname=fish-git
_gitname="fish-shell"
-pkgver=3.4.0.r53.g3e5284aaf
+pkgver=3.6.0.r217.g59fe124c4
pkgrel=1
epoch=2
pkgdesc="User friendly shell intended mostly for interactive use."
arch=('i686' 'x86_64' 'arm')
url="http://fishshell.com"
-license=("GPL2")
-depends=('glibc' 'gcc-libs' 'ncurses' 'pcre2')
-optdepends=('python: man page completion parser / web config tool'
- 'pkgfile: command-not-found hook'
- 'wl-clipboard: clipboard integration'
- 'xsel: clipboard integration'
- 'xclip: clipboard integration')
-makedepends=('cmake' 'python-sphinx' 'git')
-checkdepends=('expect')
-provides=('fish' 'fish-shell')
-conflicts=('fish' 'fish-shell')
+license=('GPL2')
+depends=(
+ 'glibc'
+ 'gcc-libs'
+ 'ncurses'
+ 'pcre2'
+)
+optdepends=(
+ 'python: man page completion parser / web config tool'
+ 'pkgfile: command-not-found hook'
+)
+makedepends=(
+ 'cargo'
+ 'clang'
+ 'cmake'
+ 'git'
+ 'python-sphinx'
+)
+checkdepends=(
+ 'expect'
+ 'procps-ng'
+)
+provides=(
+ 'fish'
+ 'fish-shell'
+)
+conflicts=(
+ 'fish'
+ 'fish-shell'
+)
+source=(
+ "git+https://github.com/fish-shell/fish-shell.git"
+)
install='fish.install'
-source=("git+https://github.com/fish-shell/fish-shell.git")
-md5sums=('SKIP')
+backup=(etc/fish/config.fish)
+b2sums=('SKIP')
pkgver() {
- cd "$_gitname"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd "$_gitname"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
-check() {
- cd "$_gitname"
- make -C build test
+build() {
+ cd "$_gitname"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake \
+ -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DCMAKE_BUILD_TYPE=None \
+ -DBUILD_DOCS=True \
+ -Wno-dev
+ make -C build
}
-build() {
- cd "$_gitname"
- export CXXFLAGS+=" ${CPPFLAGS}"
- cmake \
- -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_SYSCONFDIR=/etc \
- -DCMAKE_BUILD_TYPE=None \
- -DBUILD_DOCS=True \
- -Wno-dev
- make -C build
+check() {
+ cd "$_gitname"
+ make -C build test
}
package() {
- cd "$_gitname"
- make -C build DESTDIR="$pkgdir" install
+ cd "$_gitname"
+ make -C build DESTDIR="$pkgdir" install
}